Closed Bug 1583945 Opened 3 months ago Closed 2 months ago

Import the RDM browser stylesheet along with the devtools-browser stylesheet

Categories

(DevTools :: Responsive Design Mode, task, P3)

task

Tracking

(firefox71 fixed)

RESOLVED FIXED
Firefox 71
Tracking Status
firefox71 --- fixed

People

(Reporter: gl, Assigned: gl)

References

Details

Attachments

(1 file)

This bug is about lazily injecting the RDM stylesheet into the browser window when RDM is toggled on. This gives the ability to write custom styles for the browser elements when RDM is on. We won't deal with the layout issues that are mentioned in https://phabricator.services.mozilla.com/D45091 in this bug.

Summary: Lazily inject the RDM stylesheet into the browser window when RDM is on → Import the RDM browser stylesheet along with the devtools-browser stylesheet
Attachment #9095283 - Attachment description: Bug 1583945 - Lazily inject the RDM stylesheet into the browser window when RDM is on. r=bgrins → Bug 1583945 - Import the RDM browser stylesheet along with the devtools-browser stylesheet. r=bgrins
Blocks: 1578839
Duplicate of this bug: 1585460
Pushed by gluong@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c923f4ce93de
Import the RDM browser stylesheet along with the devtools-browser stylesheet. r=bgrins
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
You need to log in before you can comment on or make changes to this bug.