Closed Bug 1583962 Opened 2 years ago Closed 2 years ago

Intermittent dom/push/test/test_data.html | AbortError: Error retrieving push subscription. - Should not throw any errors

Categories

(Core :: DOM: Push Notifications, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1584014

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Filed by: aciure [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=268402701&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/DNYUBaunR_6druuqRtT2jQ/runs/0/artifacts/public/logs/live_backing.log


task 2019-09-25T17:47:04.204Z] 17:47:04 INFO - TEST-START | dom/push/test/test_data.html
[task 2019-09-25T17:47:05.582Z] 17:47:05 INFO - GECKO(8442) | console.error: PushServiceWebSocket:
[task 2019-09-25T17:47:05.585Z] 17:47:05 INFO - GECKO(8442) | handleHelloReply: Unexpected state
[task 2019-09-25T17:47:05.586Z] 17:47:05 INFO - GECKO(8442) | 3
[task 2019-09-25T17:47:05.586Z] 17:47:05 INFO - GECKO(8442) | (expected STATE_WAITING_FOR_HELLO)
[task 2019-09-25T17:47:05.594Z] 17:47:05 INFO - TEST-INFO | started process screentopng
[task 2019-09-25T17:47:06.244Z] 17:47:06 INFO - TEST-INFO | screentopng: exit 0
[task 2019-09-25T17:47:06.244Z] 17:47:06 INFO - Buffered messages logged at 17:47:05
[task 2019-09-25T17:47:06.245Z] 17:47:06 INFO - add_task | Entering test start
[task 2019-09-25T17:47:06.246Z] 17:47:06 INFO - add_task | Leaving test start
[task 2019-09-25T17:47:06.246Z] 17:47:06 INFO - add_task | Entering test createControlledIFrame
[task 2019-09-25T17:47:06.247Z] 17:47:06 INFO - add_task | Leaving test createControlledIFrame
[task 2019-09-25T17:47:06.248Z] 17:47:06 INFO - add_task | Entering test subscribe
[task 2019-09-25T17:47:06.249Z] 17:47:06 INFO - Buffered messages finished
[task 2019-09-25T17:47:06.250Z] 17:47:06 INFO - TEST-UNEXPECTED-FAIL | dom/push/test/test_data.html | AbortError: Error retrieving push subscription. - Should not throw any errors
[task 2019-09-25T17:47:06.251Z] 17:47:06 INFO - Asyncsubscribe@http://mochi.test:8888/tests/dom/push/test/test_data.html:63:55
[task 2019-09-25T17:47:06.252Z] 17:47:06 INFO - nextTick/<@http://mochi.test:8888/tests/SimpleTest/SimpleTest.js:1795:34
[task 2019-09-25T17:47:06.253Z] 17:47:06 INFO - async
nextTick@http://mochi.test:8888/tests/SimpleTest/SimpleTest.js:1811:11
[task 2019-09-25T17:47:06.254Z] 17:47:06 INFO - setTimeout handlerSimpleTest_setTimeoutShim@http://mochi.test:8888/tests/SimpleTest/SimpleTest.js:686:43
[task 2019-09-25T17:47:06.255Z] 17:47:06 INFO - add_task@http://mochi.test:8888/tests/SimpleTest/SimpleTest.js:1755:17
[task 2019-09-25T17:47:06.256Z] 17:47:06 INFO - @http://mochi.test:8888/tests/dom/push/test/test_data.html:47:11
[task 2019-09-25T17:47:06.266Z] 17:47:06 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-09-25T17:47:06.267Z] 17:47:06 INFO - TEST-UNEXPECTED-FAIL | dom/push/test/test_data.html | This test left a service worker registered without cleaning it up
[task 2019-09-25T17:47:06.269Z] 17:47:06 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:277:18
[task 2019-09-25T17:47:06.270Z] 17:47:06 INFO - afterCleanup@SimpleTest/SimpleTest.js:1192:28
[task 2019-09-25T17:47:06.274Z] 17:47:06 INFO - async
executeCleanupFunction@SimpleTest/SimpleTest.js:1232:13
[task 2019-09-25T17:47:06.275Z] 17:47:06 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-09-25T17:47:06.276Z] 17:47:06 INFO - TEST-UNEXPECTED-FAIL | dom/push/test/test_data.html | Left over worker: http://mochi.test:8888/tests/dom/push/test/worker.js?0.8513972719194862 (scope: http://mochi.test:8888/tests/dom/push/test/)
[task 2019-09-25T17:47:06.277Z] 17:47:06 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:277:18
[task 2019-09-25T17:47:06.278Z] 17:47:06 INFO - afterCleanup@SimpleTest/SimpleTest.js:1194:32
[task 2019-09-25T17:47:06.279Z] 17:47:06 INFO - async*executeCleanupFunction@SimpleTest/SimpleTest.js:1232:13
[task 2019-09-25T17:47:06.280Z] 17:47:06 INFO - GECKO(8442) | MEMORY STAT vsizeMaxContiguous not supported in this build configuration.
[task 2019-09-25T17:47:06.281Z] 17:47:06 INFO - GECKO(8442) | MEMORY STAT | vsize 2522MB | residentFast 127MB | heapAllocated 18MB
[task 2019-09-25T17:47:06.282Z] 17:47:06 INFO - TEST-OK | dom/push/test/test_data.html | took 1425ms
[task 2019-09-25T17:47:06.283Z] 17:47:06 ERROR - /tests/dom/push/test/test_data.html logged result after SimpleTest.finish(): This test left a service worker registered without cleaning it up
[task 2019-09-25T17:47:06.284Z] 17:47:06 ERROR - /tests/dom/push/test/test_data.html logged result after SimpleTest.finish(): Left over worker: http://mochi.test:8888/tests/dom/push/test/worker.js?0.8513972719194862 (scope: http://mochi.test:8888/tests/dom/push/test/)

Regression from bug 1369436?

Flags: needinfo?(emalysz)
Regressed by: 1369436

Submitting a patch soon to bug 1584014 that will correct this issue

Flags: needinfo?(emalysz)

Bug 1584014 fixes the regression

Flags: needinfo?(aryx.bugmail)

Thank you for the quick fix.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(aryx.bugmail)
Resolution: --- → DUPLICATE
Duplicate of bug: 1584014
You need to log in before you can comment on or make changes to this bug.