Closed Bug 1584439 Opened 19 days ago Closed 13 days ago

Enable picture caching for scroll bars and UI content

Categories

(Core :: Graphics: WebRender, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: gw, Assigned: gw)

References

(Regressed 1 open bug)

Details

Attachments

(1 file)

No description provided.
Assignee: nobody → gwatson

Once this patch lands, all content drawn by WebRender is drawn into
a picture cache surface.

This will incur some extra GPU memory overhead since there are extra
GPU texture buffers. Much of this can be reduced by adding a couple
of simple optimizations in future to detect tiles that are solid
colors only.

With this change, we'll now be able to provide exact dirty rects for
the entire screen without any hacks, and start the work to draw into
OS compositor surfaces directly.

Pushed by gwatson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4f126cfd8012
Enable picture caching for scroll bars and UI content. r=nical

I've updated the fuzziness annotations for those tests on pixel2, thanks!

Flags: needinfo?(gwatson)
Pushed by gwatson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3eba60b905c0
Enable picture caching for scroll bars and UI content. r=nical

Hmm, there doesn't seem to be anything obviously wrong in the log files - I wonder if it's crashing but not including any crash information in the log output. Can you see anything in the logs that looks like an application error or crash?

Otherwise, I'll try to add some extra logging information and debug on try and/or a local android build tomorrow.

Flags: needinfo?(gwatson)

It does look like it stops running before all the reftests complete, since the output finishes earlier than I'd expect. But then it doesn't seem to include any crash details, and just seems to continue on with the script.

I ran this locally on a pixel2 device.

I found that there was one more test that was failing due to fuzziness. The output is being truncated on the try server for some reason, which is why I couldn't see a failure.

I've updated the fuzziness, and confirmed that they all pass on my pixel2 device. I've kicked off another try run [1] to be safe, then this should hopefully be ready to land again.

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=fbe2ecef8e9d808d585e06c35e5370d15e52a7da

Pushed by gwatson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9b42bdc4889f
Enable picture caching for scroll bars and UI content. r=nical
Status: NEW → RESOLVED
Closed: 13 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

Seems to have caused bug 1585898.

You need to log in before you can comment on or make changes to this bug.