Remove "Enable Internet Keywords" pref

VERIFIED DUPLICATE of bug 158446

Status

VERIFIED DUPLICATE of bug 158446
16 years ago
10 years ago

People

(Reporter: bugzilla, Assigned: bugzilla)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

16 years ago
We currently allow the user to turn off Internet Keywords from the Navigator >
Smart Browsing pref panel.  This appears to also turn off searching from the url
bar.  This pref is useless, because if you turn it off and enter a
space-separated phrase in the urlbar, you just get an alert saying "The URL is
not valid and cannot be loaded."

We should either:
* remove the pref entirely
* make this pref not control searches, which would give some utility to the pref

The latter might be difficult since I think right now the decision to fallback
to search is made on the server-side (i.e., we just pass phrases to
info.netscape.com and it decides whether it's an Internet keyword or a search
phrase).  Since the pref is useless in it's current form, I say let's remove it.
(Assignee)

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 158446 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.