Closed Bug 1584491 Opened 6 months ago Closed 6 months ago

Change xpcshell configuration for toolkit search tests so that duplicate tests are run correctly

Categories

(Firefox :: Search, task, P1)

task
Points:
1

Tracking

()

RESOLVED FIXED
Firefox 71
Iteration:
71.2 - Sept 16 - 29
Tracking Status
firefox71 --- fixed

People

(Reporter: standard8, Assigned: standard8)

References

Details

Attachments

(2 files)

Currently when running the xpcshell-tests in toolkit/components/search we can occasionally get some warnings about tests reporting whilst the same test is still in progress.

We also don't see a distinction in the test names between xpcshell and xpcshell-legacy, which makes it harder to know what's going on.

I tracked this down to us needing a common file where the tests are imported from. Hence the patches coming up.

I'm also doing a separate patch to re-order the tests into alphabetical order, since this makes it easier to find entries and know where to insert entries.

The duplicate tests are for legacy vs modern configurations.

Blocks: 1582942
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/269ed5bcfede
Change xpcshell configuration for toolkit search tests so that duplicate tests are run correctly. r=mak
https://hg.mozilla.org/integration/autoland/rev/1b9b259dedb1
Sort search's toolkit tests into alphabetical order, because it is nice and makes tests easier to find. r=mak
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

test_json_cache_broken.js and test_json_cache_good.js were switched off for TB in bug 1582086. Then they were switched off generally and now they are switched on generally and fail for TB. Do I need to file another bug or can you please switch them off again here.

See:
https://hg.mozilla.org/mozilla-central/rev/89b9b3aa3aafb413060c61e381723c0788c07848
https://hg.mozilla.org/mozilla-central/rev/14789caee8bdde35e40a3bafa3ec7c786b8bc9f1#l8.70
https://hg.mozilla.org/mozilla-central/rev/14789caee8bdde35e40a3bafa3ec7c786b8bc9f1#l9.69

Flags: needinfo?(standard8)
Regressions: 1585193
Flags: needinfo?(standard8)
You need to log in before you can comment on or make changes to this bug.