Closed Bug 1584684 Opened 5 months ago Closed 5 months ago

Perma fission [tier2] devtools/client/webconsole/test/browser/browser_webconsole_warning_group_content_blocking.js | Test timed out -

Categories

(DevTools :: Console, defect, P5)

defect

Tracking

(Fission Milestone:M4, firefox-esr60 unaffected, firefox-esr68 unaffected, firefox67 unaffected, firefox68 unaffected, firefox69 unaffected, firefox70 unaffected, firefox71 fixed)

RESOLVED FIXED
Firefox 71
Fission Milestone M4
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: annyG)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: intermittent-failure, regression)

Filed by: dvarga [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=268866585&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/NsiHJz-LReGpUvgdxs5ZFQ/runs/0/artifacts/public/logs/live_backing.log


[task 2019-09-27T23:15:50.091Z] 23:15:50     INFO - TEST-START | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_content_blocking.js
[task 2019-09-27T23:17:20.154Z] 23:17:20     INFO - TEST-INFO | started process screenshot
[task 2019-09-27T23:17:20.234Z] 23:17:20     INFO - TEST-INFO | screenshot: exit 0
[task 2019-09-27T23:17:20.234Z] 23:17:20     INFO - Buffered messages logged at 23:15:50
[task 2019-09-27T23:17:20.234Z] 23:17:20     INFO - Entering test bound cleanUp
[task 2019-09-27T23:17:20.234Z] 23:17:20     INFO - Leaving test bound cleanUp
[task 2019-09-27T23:17:20.234Z] 23:17:20     INFO - Entering test bound testContentBlockingMessage
[task 2019-09-27T23:17:20.235Z] 23:17:20     INFO - Adding a new tab with URL: http://tracking.example.org/browser/devtools/client/webconsole/test/browser/test-warning-groups.html
[task 2019-09-27T23:17:20.235Z] 23:17:20     INFO - Tab added and finished loading
[task 2019-09-27T23:17:20.235Z] 23:17:20     INFO - Buffered messages logged at 23:15:51
[task 2019-09-27T23:17:20.235Z] 23:17:20     INFO - Test content blocking message
[task 2019-09-27T23:17:20.235Z] 23:17:20     INFO - Console message: [JavaScript Warning: "The resource at “http://tracking.example.com/?1&1569626151253” was blocked because content blocking is enabled." {file: "about:blank" line: 0}]
[task 2019-09-27T23:17:20.235Z] 23:17:20     INFO - Buffered messages logged at 23:16:35
[task 2019-09-27T23:17:20.235Z] 23:17:20     INFO - Longer timeout required, waiting longer...  Remaining timeouts: 1
[task 2019-09-27T23:17:20.236Z] 23:17:20     INFO - Buffered messages finished
[task 2019-09-27T23:17:20.236Z] 23:17:20     INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_content_blocking.js | Test timed out - 
[task 2019-09-27T23:17:20.236Z] 23:17:20     INFO - GECKO(11172) | MEMORY STAT | vsize 2105264MB | vsizeMaxContiguous 65015298MB | residentFast 682MB | heapAllocated 156MB
[task 2019-09-27T23:17:20.236Z] 23:17:20     INFO - TEST-OK | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_content_blocking.js | took 90136ms
[task 2019-09-27T23:17:20.254Z] 23:17:20     INFO - checking window state
[task 2019-09-27T23:17:20.254Z] 23:17:20     INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-09-27T23:17:20.254Z] 23:17:20     INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_content_blocking.js | Found a browser window after previous test timed out - 
[task 2019-09-27T23:17:20.255Z] 23:17:20     INFO - GECKO(11172) | must wait for focus
Summary: Intermittent devtools/client/webconsole/test/browser/browser_webconsole_warning_group_content_blocking.js | Test timed out - → Perma fission [tier2] devtools/client/webconsole/test/browser/browser_webconsole_warning_group_content_blocking.js | Test timed out -

This is most likely because of me removing the skip-if annotation. I have a patch I am testing right now to double check this.

This should be fixed now in bug 1582531, as I changed the annotation for this test.

Flags: needinfo?(agakhokidze)

No new failures since Oct 2.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Assignee: nobody → agakhokidze
Target Milestone: --- → Firefox 71

Retroactively moving fixed bugs whose summaries mention "Fission" (or other Fission-related keywords) but are not assigned to a Fission Milestone to an appropriate Fission Milestone.

This will generate a lot of bugmail, so you can filter your bugmail for the following UUID and delete them en masse:

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: --- → M4
You need to log in before you can comment on or make changes to this bug.