Status

()

Core
Layout: HTML Frames
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: Eugen, Assigned: John Keiser (jkeiser))

Tracking

({verifyme})

Trunk
x86
Windows XP
verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

The navigation frame on the left is shown, but the main frame is not shown. In
IE both frames are shown.

Reproducible: Always
Steps to Reproduce:
1. goto the above link


Actual Results:  Main frame is not shown.

Expected Results:  Main frame must be shown.
wfm with win2k build 20020720..
linux trunk cvs 2002-07-19

Two problems:

1) I do get the main frame - in a pop-up window. Reloading loads the content
   in the main frame; also clicking on the links in the menu on the left does
   load main frame contents in the proper place.

2) The navigation frame at left bottom,
  
<http://www.fh-konstanz.de/Studium/fachb/in/wwwin/navi_script/navi_studium_ti.htm>,
   has <body ... onLoad="window.open('../ti/ti_home.htm','content_frame');">
   and that will not work if pop-up blocking is on.

  The changing of the main frame content when a link in the nav frame is
  clicked is done similarly by changing the location of the nav frame to
  ./navi_studium_??.htm or similar, and then that page using the onLoad event
  to window.open the content in the main frame. Which will not work if pop-up
  blocking is turned on.

Problem 2 is already filed, as bug 104470.

Regarding problem 1, that appears to be a race condition of sorts, where the
onLoad event in

    <frameset>
      <frameset>
        <frame/>
        <frame>
          <html etcetc..>
            <body  [[[HERE]]] />
        </frame>
      </frameset>
      <frame name='content_frame' />
    </frameset>

gets triggered before the name='content_frame' gets established, resulting in
a pop-up window ...as on reload, the frame is there already, (right?)... so the
window.open call hits the frame correctly.

Reporter, please verify that the page works correctly when pop-up blocking (edit
> preferences > advanced > scripts&pplugins > allow scripts to: open unrequested
windows) is turned off, and comment here on the result.
(Reporter)

Comment 3

16 years ago
OK, works when "open unrequested windows" is enabled, sorry for the trouble.

Comment 4

16 years ago
According to reporter, it's a matter of the local preferences, and is not a bug.

==> INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Updated

16 years ago
Keywords: verifyme

Comment 5

16 years ago
Verified. Invalid
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.