Closed Bug 1584720 Opened 5 months ago Closed 5 months ago

Right click context menu would not pop up on "Search filter by name..." Message Filters. And no placeholder.

Categories

(Thunderbird :: Filters, defect)

Desktop
Windows 10
defect
Not set

Tracking

(thunderbird_esr60 unaffected, thunderbird_esr6870+ fixed, thunderbird68 wontfix, thunderbird69 wontfix, thunderbird70 fixed, thunderbird71 fixed)

VERIFIED FIXED
Thunderbird 71.0
Tracking Status
thunderbird_esr60 --- unaffected
thunderbird_esr68 70+ fixed
thunderbird68 --- wontfix
thunderbird69 --- wontfix
thunderbird70 --- fixed
thunderbird71 --- fixed

People

(Reporter: alice0775, Assigned: mkmelin)

References

(Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(2 files)

STR

  1. Hamburger Menu > Message Filters > Message Filters
    --- observe placeholder of Search field at top of dialog
  2. Right click on Search field at top of dialog
    --- observe context menu

Actual results:
No placeholder displays
No Context menu

Expected Results:
"Search filters by name..." should display
Edit context menu should pop up

Regression window:
https://hg.mozilla.org/comm-central/pushloghtml?fromchange=0578849d7c953f13f6b8c6c57c1054b5a445c317&tochange=55a635377bed6cdeb57175d7e25a67b34dfce540
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a42caa9f04fc41044437ac56eab6f6086c841d9f&tochange=2abcefb31ba7b2a1c573edc5695b772826c6a078

Regressed by:
55a635377bed6cdeb57175d7e25a67b34dfce540 Magnus Melin — Bug 1534913 - Port bug 1521280 [Remove search-textbox binding] to Thunderbird. r=jorgk

Version: 71 → 68
Flags: needinfo?(mkmelin+mozilla)
Summary: Right click context menu would not pop up on "Search filter by name..." Message Filters. And no placegolder. → Right click context menu would not pop up on "Search filter by name..." Message Filters. And no placeholder.

This should cover all the places

Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Flags: needinfo?(mkmelin+mozilla)
Attachment #9097121 - Flags: review?(jorgk)
Comment on attachment 9097121 [details] [diff] [review]
bug1584720_search-textbox_context.patch

Doesn't restore the emptytext="&searchBox.emptyText;"

Sadly I also noticed bug 1584754. Did you not notice that?
Attachment #9097121 - Flags: review?(jorgk) → review-

If you change it to "placeholder" it works.

Attachment #9097166 - Flags: review+
Comment on attachment 9097166 [details] [diff] [review]
bug1584720_search-textbox_context.patch

I guess we only forked the password manager recently, so that hunk will not apply to TB 68.
Attachment #9097166 - Flags: approval-comm-esr68+
Attachment #9097166 - Flags: approval-comm-beta+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/6881607913e5
follow-up to bug 1534913 to let search-textbox have a context menu. r=jorgk

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 71.0

Works on the beta incl. the placeholder.

Status: RESOLVED → VERIFIED

https://hg.mozilla.org/releases/mozilla-esr68/rev/a6c1404320a72f4ef64dbb87335b013b5963e05e on THUNDERBIRD_68_VERBRANCH

That's for the password manager which in TB 68 was still in the Mozilla platform code. Since somehow the "Saved Logins" show a context menu in FF 68.1 ESR, I put the fix onto our branch without further ado. A similar fix was approved in bug 1584795 comment #15.

You need to log in before you can comment on or make changes to this bug.