Closed Bug 1584780 Opened 2 months ago Closed 2 months ago

layout.css.xul-box-display-values.survive-blockification.enabled breaks CFR panels

Categories

(Firefox :: Messaging System, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 71
Iteration:
71.3 - Sept 30 - Oct 13
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- verified

People

(Reporter: asa, Assigned: andreio)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

Attached image image.png

Since enabling layout.css.xul-box-display-values.survive-blockification.enabled CFR panels are kind of a mess.

Component: Layout → Theme
Product: Core → Firefox
Has Regression Range: --- → yes
Keywords: regression
Blocks: cfr
Iteration: --- → 71.3 - Sept 30 - Oct 13
Component: Theme → Messaging System
Priority: -- → P1
Assignee: nobody → andrei.br92
Attached image 51b9309e6f.png (obsolete) —

It also breaks my vertical tabs (via the "Tab Center Redux" addon), adding a black bar just right of the collapsed tabs.
On hover, the whole viewpoint shrinks, moving over content.

After disabling that flag behavior is back to normal and the vertical tab bar expands by overlaying the viewport.

Comment on attachment 9097404 [details]
51b9309e6f.png

Please file a separate bug.
Attachment #9097404 - Attachment is obsolete: true
See Also: → 1585616
Duplicate of this bug: 1585616

FYI: I believe this bug means that these panels aren't tested in automation, since before Bug 1582530 landed there were try pushes that would have crashed had it hit this case.

(In reply to Brian Grinstead [:bgrins] from comment #5)

FYI: I believe this bug means that these panels aren't tested in automation, since before Bug 1582530 landed there were try pushes that would have crashed had it hit this case.

Those try pushes didn’t include asserts for the display: flex cases, since a lot of the CSS that was caught by that display:flex assert didn’t require any change after unblockification from manual testing.

We can potentially revisit this by re-applying the assert, fixing all the cases one-by-one, removing the assert and then unapplying the “fixes” that make no differences.

(In reply to Tim Nguyen :ntim from comment #6)

(In reply to Brian Grinstead [:bgrins] from comment #5)

FYI: I believe this bug means that these panels aren't tested in automation, since before Bug 1582530 landed there were try pushes that would have crashed had it hit this case.

Those try pushes didn’t include asserts for the display: flex cases, since a lot of the CSS that was caught by that display:flex didn’t require any change after unblockification from manual testing.

We can potentially revisit this by re-applying the assert, fixing all the cases one-by-one, removing the assert and then unapplying the “fixes” that make no differences.

Thanks for the clarification - nevermind then.

Pushed by aoprea@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e89c795c2260
layout.css.xul-box-display-values.survive-blockification.enabled breaks CFR panels r=dao
See Also: → 1586369
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Flags: qe-verify+

I have verified this issue on Firefox Beta 71.0 (Build ID:20191125204040) and Latest Firefox Nightly 72.0a1 (Build ID: 20191128094109) on Windows 10 x64, Mac 10.14.6 and Arch Linux 3.34.1.
All elements from the CFR panels are correctly displayed.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.