Closed Bug 1584812 Opened 5 months ago Closed 5 months ago

Port Bug 1562684 "[10.15][Mac] PR_GetLibraryFilePathname is returning absolute paths in MacOS Catalina" to SeaMonkey

Categories

(SeaMonkey :: Build Config, enhancement)

enhancement
Not set

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.63 wontfix)

RESOLVED FIXED
seamonkey2.68
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed
seamonkey2.63 --- wontfix

People

(Reporter: frg, Assigned: frg)

Details

Attachments

(1 file)

See Bug 1562684 Comment 31
Local builds on 10.15 seem to fail now. Because it will be released soon we should port the Mozilla bug.

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: Local builds on macOS 10.15 fail.
Testing completed (on m-c, etc.): 2.53 cross-compile only
Risk to taking this patch (and alternatives if risky): low risk
String changes made by this patch: --

Attachment #9097204 - Flags: review?(iann_bugzilla)
Attachment #9097204 - Flags: approval-comm-release?
Attachment #9097204 - Flags: approval-comm-esr60?
Comment on attachment 9097204 [details] [diff] [review]
1584812-macos1015-build.patch

[Triage Comment]
LGTM r/a=me
Attachment #9097204 - Flags: review?(iann_bugzilla)
Attachment #9097204 - Flags: review+
Attachment #9097204 - Flags: approval-comm-release?
Attachment #9097204 - Flags: approval-comm-release+
Attachment #9097204 - Flags: approval-comm-esr60?
Attachment #9097204 - Flags: approval-comm-esr60+

Geoff,

this might affect TB also. It seems only be critical if someone builds locally under 10.15 and might even be fixed by the time 10.15 is released. If you want I can do a TB patch but unable to test because these days I usually cross compile for macOS and just test there. Seems to be a 1:1 patch for Firefox too in TB.

Flags: needinfo?(geoff)

Thanks, I'll steal what Firefox did and apply it to Thunderbird. Not that I build for Mac or really understand the problem. ;-)

Flags: needinfo?(geoff)

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/665db3e150ae
PR_GetLibraryFilePathname is returning absolute paths in MacOS Catalina. r=IanN

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.