Closed Bug 1584819 Opened 6 months ago Closed 6 months ago

Crash in [@ mozilla::dom::WindowGlobalParent::Init]

Categories

(Core :: DOM: Navigation, defect, critical)

Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1584467
Tracking Status
firefox71 + fixed

People

(Reporter: pascalc, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-ed8359f8-e9cd-461c-9834-ebe700190928.

Top 10 frames of crashing thread:

0 xul.dll mozilla::dom::WindowGlobalParent::Init dom/ipc/WindowGlobalParent.cpp:90
1 xul.dll mozilla::dom::BrowserParent::RecvNewWindowGlobal dom/ipc/BrowserParent.cpp:1268
2 xul.dll mozilla::dom::PBrowserParent::OnMessageReceived ipc/ipdl/PBrowserParent.cpp:6290
3 xul.dll mozilla::dom::PContentParent::OnMessageReceived ipc/ipdl/PContentParent.cpp:5873
4 xul.dll mozilla::ipc::MessageChannel::DispatchMessage ipc/glue/MessageChannel.cpp:2109
5 xul.dll mozilla::ipc::MessageChannel::MessageTask::Run ipc/glue/MessageChannel.cpp:1985
6 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1225
7 xul.dll NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:486
8 xul.dll mozilla::ipc::MessagePump::Run ipc/glue/MessagePump.cpp:88
9 xul.dll MessageLoop::RunHandler ipc/chromium/src/base/message_loop.cc:308

This is a spiking on Nightly 71 over the last 2 days.

Component: General → DOM: Core & HTML

Crash reason is: MOZ_DIAGNOSTIC_ASSERT(!mBrowsingContext->GetParent() || mBrowsingContext->GetEmbedderInnerWindowId()) (When creating a non-root WindowGlobalParent, the WindowGlobalParent for our embedder should've already been created.)

Possible regression range: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1d189ae70326e415f8590e3aeee24885fb8418bc&tochange=aa8f530a1a35ba9b1c84303dbe15107d0026d77c

Nika, any ideas? I see that bug 1582237 is in the regression range and involves inner window IDs, and the assertion also seems to involve them.

Flags: needinfo?(nika)
Component: DOM: Core & HTML → Document Navigation

Around half of the crashes seem to have Roblox URLs.

I believe this is caused by the same issue as bug 1584467, which I have a patch up for.

Resolving as a duplicate, but feel free to re-open if the landing doesn't fix the issue.

Status: NEW → RESOLVED
Closed: 6 months ago
Flags: needinfo?(nika)
Resolution: --- → DUPLICATE
Duplicate of bug: 1584467

Reflecting firefox71-status of bug 1584467

You need to log in before you can comment on or make changes to this bug.