Status

()

enhancement
VERIFIED DUPLICATE of bug 162871
17 years ago
16 years ago

People

(Reporter: mar_garina, Assigned: Matti)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

17 years ago
Looks like mozilla caches the dns (or any other hostname-resolution method)
results- If I'm updating an A record in my local dns, mozilla will still use the
old value until I'll restart it.
I don't see a reason for internal caching of hosts/IPs anyway- I think that's
the job of the os (i.e. many unices are running nscd), and besides, hostname
resolution is a quite fast operation usually.

Comment 1

17 years ago
From comment #2 for bug 109313 (linux specific):

> It's really glibc that's caching /etc/resolv.conf so it's sort of a 
> system issue. There are ways around it but they're very non-standard.

Component: Browser-General → Networking
Whiteboard: dupeme

*** This bug has been marked as a duplicate of 109313 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
DNS servers are not "cached", they just kind of get stuck in most Linux builds.
(To me cache implies we did this on purpose for some performance reason).

Status: RESOLVED → UNCONFIRMED
QA Contact: asa → benc
Resolution: DUPLICATE → ---
Summary: Mozilla seems to cache the dns results → DNS: seems to cache results

Comment 4

17 years ago
Bug 162871 is the current DNS cache implementation discussion.

reporter: Please look at it and VERIFY if the problem descriptions are duplicates.


*** This bug has been marked as a duplicate of 162871 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago17 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme

Comment 5

16 years ago
VERIFIED/dupe.

This is all changing in 1.6a's DNS rewrite anyhow.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.