Closed Bug 1585238 Opened 2 years ago Closed 2 years ago

Outline panel class function icon is invisible

Categories

(DevTools :: Debugger, defect, P2)

71 Branch
defect

Tracking

(firefox71 verified)

VERIFIED FIXED
Firefox 71
Tracking Status
firefox71 --- verified

People

(Reporter: chujunlu, Assigned: chujunlu)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Attached image before.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.90 Safari/537.36

Steps to reproduce:

Follow-up UI bug for https://bugzilla.mozilla.org/show_bug.cgi?id=1574581
1.Open https://send.firefox.com/
2.Open debugger then open file: webpack:///app/ece.js
3.Click "Outline" tab

Actual results:

The "λ" icon in front of the class function is white, which is not visible. It only reveals when I hover the function so the background color of the function changes. Not sure if that's intentional?

Expected results:

Before patch for 1574581 was landed, the "λ" icon was black.

Attached image after.png
Blocks: dbg-frontend
Priority: -- → P2
Blocks: 1574581
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2ff4b06327e7
Make class function icon visible in outline panel r=jlast
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Assignee: nobody → chujunlu
Flags: qe-verify+

Hello! Reproduced the issue using Firefox 71.0a1 (20190930215436) on Windows 10x64.
The issue is verified fixed with Firefox 71.0b11 (20191118154140) on Windows 10x64, macOS 10.14 and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.