Status

VERIFIED DUPLICATE of bug 153562
17 years ago
3 years ago

People

(Reporter: jonjgc, Assigned: ccarlen)

Tracking

Trunk
x86
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I only use one profile, so there should be no need to enter the profile manager.
However, quite often, and always after crashes, I am told my default directory
is not available, please select a new profile.

I have tracked down the problem to a scrambling of part of the appreg file.

At the end of the 30K appreg file is a copy of the path to my default (only)
profile.  When the problem occurs this path is shifted 3 bytes further into the
file, with 3 characters preceeding the leading "/" of the path.  Each of these
characters is > 127 (non-ascii).  The path normally ends in ".slt".  When
corrupted, the last character of the file is the "l".

I can repair the file with a binary editor and all seems fine again until
another crash or ???

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 153562 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Dupe of bug 153562. There's activity on that bug so I'll add Jon's comment to it.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.