Closed Bug 1585456 Opened 1 year ago Closed 1 year ago

[mozproxy] Error out when mozproxy can't bind to port

Categories

(Testing :: Mozbase, defect, P1)

Version 3
defect

Tracking

(firefox73 fixed)

RESOLVED FIXED
mozilla73
Tracking Status
firefox73 --- fixed

People

(Reporter: nalexander, Assigned: Bebe)

References

Details

Attachments

(1 file)

I have a lot of things running on the systems that I run mach raptor-test on, and frequently port 8080 isn't available. In this case Raptor kinda-sorta works, but it doesn't actually work 'cuz the proxy isn't running. The Raptor harness doesn't handle that situation: no bueno.

This ticket tracks failing harder in that situation.

The priority flag is not set for this bug.
:davehunt, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(dave.hunt)

Bebe: can you assign this to someone to look into? There's a risk here of misrepresenting performance if the live sites are used instead of mozproxy and the recordings.

Component: Performance → Mozbase
Flags: needinfo?(dave.hunt) → needinfo?(fstrugariu)
Priority: -- → P1
Summary: Make `mozproxy` error out when it can't bind to its port → [mozproxy] Error out when mozproxy can't bind to port

in the https://searchfox.org/mozilla-central/source/testing/mozbase/mozproxy/mozproxy/backends/mitm/mitm.py#279

we check if a proxy is available and ready but we just do a socket connect to make sure the host:port is on.

What if we do a get and request from the proxy the pid that is running on.
then we can compare the started pid with the actual pid from the proxy and confirm we are using the correct proxy service.

Flags: needinfo?(tarek)
Flags: needinfo?(fstrugariu)
Flags: needinfo?(dave.hunt)
Assignee: nobody → fstrugariu
Status: NEW → ASSIGNED

I don't think that addresses Nick's concern. what we want to do is use an available port. so instead of hardcoding 8080, we could use the first available port on the system. We just need to make sure that we can set that port everywhere in Raptor at that moment, because the 8080 setting is propagated in several spots.

And if we can't do that and the port is busy, we should just error out.

Flags: needinfo?(tarek)
Flags: needinfo?(dave.hunt)
Pushed by fstrugariu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ea612d6aa75b
[mozproxy] Error out when mozproxy can't bind to port r=tarek,perftest-reviewers,davehunt
Regressions: 1593351
Backout by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/275c78492eea
Backed out changeset ea612d6aa75b for causing regressions (Bug 1593351,1587387,1583680).
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla72 → ---
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
Flags: needinfo?(fstrugariu)
You need to log in before you can comment on or make changes to this bug.