Accepting Duplicate POST from the SAME IP/User-Agent

RESOLVED DUPLICATE of bug 42946

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED DUPLICATE of bug 42946
16 years ago
5 years ago

People

(Reporter: Benoît Rouits, Assigned: myk)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
Bugzilla seems to accept duplicate POST from a browser, then it is really
annonying because one can easily duplicate her/his last submit just by pressing
"Back" on her/his browser, thus, incrementing a new #bug with the same content.

Comment 1

15 years ago
I too see people commonly submit a new bug, but realize they wanted to add 
more details to the bug, so they hit back, and submit again (rather than going 
to the newly opened bug and adding more detail. 

This could be prevented by dynamically outputting the blank bug form with a 
hidden form field containing random server-generated token, and only allow one 
bug to be opened with that token.  (Advanced users would have to reload the 
page if they were in the habit of pressing back, clearing the fields, and 
entering new data to open multiple bugs rapidly.)

Comment 2

15 years ago
this is a possible solution for bug 42946; bug 46843 is another possible
solution to the same problem, which is also discussed in bug 22353. fixing any
one of the bugs would resolve the problem...

*** This bug has been marked as a duplicate of 42946 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.