Closed Bug 1585617 Opened 5 months ago Closed 5 months ago

convert remaining <textbox> usages in javascript to using html:input

Categories

(Thunderbird :: General, task, P1)

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 71.0

People

(Reporter: mkmelin, Assigned: aleca)

References

Details

Attachments

(1 file, 1 obsolete file)

Assignee: nobody → alessandro
Status: NEW → ASSIGNED

(In reply to Jorg K (GMT+2) from comment #1)

And calendar?
https://searchfox.org/comm-central/search?q=%3Ctextbox&case=false&regexp=false&path=calendar

I'll take care of the calendar stuff in a dedicated bug, thanks for the heads up.

Please do.
inputField also doesn't exist anymore, so check these: https://searchfox.org/comm-central/search?q=%5C.inputField&case=false&regexp=true&path=%5Email (textbox.inputField is just the textbox, or rather the html:input now)

Attached patch 1585617-textbox-html-input.patch (obsolete) — Splinter Review

This patch should include everything, except the qfbTextbox.inputField which is correct because it's a field inside the search-textbox custom element.

Here's the try run to see how many million tests I broke: https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=d84cd53d3c98e8e909470d1d39e1156148e2f77c

Attachment #9098659 - Flags: review?(mkmelin+mozilla)

Wow, all the tests are green, sweet!

Comment on attachment 9098659 [details] [diff] [review]
1585617-textbox-html-input.patch

Review of attachment 9098659 [details] [diff] [review]:
-----------------------------------------------------------------

::: mail/components/compose/content/dialogs/EdDialogCommon.js
@@ +191,2 @@
>      // XXX Using the setTimeout is hacky workaround for bug 103197
> +    // Must create a new function to keep "input" in scope

Pretty sure this hack of a functnion could just go now...

::: mail/components/im/content/joinchat.js
@@ +70,5 @@
>        let div2 = document.createElementNS(
>          "http://www.w3.org/1999/xhtml",
>          "div"
>        );
> +      let textbox = document.createElementNS(

could be nice to update the name to be input instead
Attachment #9098659 - Flags: review?(mkmelin+mozilla) → review+

I updated the patch, but I can't test it as I'm getting a segfault since this morning.
I'm asking a quick feedback review from Magnus just to be sure everything works and I didn't introduce any bug.

Attachment #9098659 - Attachment is obsolete: true
Attachment #9098923 - Flags: review+
Attachment #9098923 - Flags: feedback?(mkmelin+mozilla)
Comment on attachment 9098923 [details] [diff] [review]
1585617-textbox-html-input.patch

I fixed my segfault issue and texted this locally.
Everything seems to work as expected.
I launched a try-run just to be sure: https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=eeed4e6593ac56e4d04bada923c3dc2baa100c42
Attachment #9098923 - Flags: feedback?(mkmelin+mozilla)

A couple of failures in Z4 and Z3 which I can't reproduce locally.
Any insight on this, Jorg?

Flags: needinfo?(jorgk)

The Z4 is known, I've rerun the Z3.

Flags: needinfo?(jorgk)

I did another try-run here: https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=8a7efd5a0e1ee9317470f82f25ef1b09cadbb38d
The Z3 and Z4 are green, but now X3 are failing, but since other patches are part of the try run I don't think it's my fault...hopefully.

Maybe this can be checked in? Is the last bit to complete the textbox removal.

X3, see bug 1587199.

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/0daedafc7c20
convert remaining <textbox> usages in JavaScript to using html:input. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 71.0
You need to log in before you can comment on or make changes to this bug.