Closed Bug 1585661 Opened 2 months ago Closed 21 days ago

Move Geckoview docs to mozilla central

Categories

(GeckoView :: General, enhancement, P2)

Unspecified
All
enhancement

Tracking

(firefox71 wontfix, firefox72 fixed)

RESOLVED FIXED
mozilla72
Tracking Status
firefox71 --- wontfix
firefox72 --- fixed

People

(Reporter: fluffyemily, Assigned: fluffyemily)

References

(Blocks 2 open bugs)

Details

Attachments

(4 files, 2 obsolete files)

Currently our documentation site is on github where all our user documentation is kept. This means that our documentation is not kept in the same place as our codebase. There are many disadvantages to this, such as it prevents us from doing things like importing example code from building source, which may result in our documentation not being up to date with changes and also means that we cannot tie documentation examples to the CHANGELOG or api.txt.

This bug is the first stage in addressing these issues - moving all of the markdown and examples that form the basis of our documentation site into Mozilla Central, and updating the github site documentation in the same way that we currently do with our Javadoc (copying from mc to gh).

Part of this issue may be looking at how we can lock down the github site to prevent commits from happening directly there, forcing all changes to come from edits in mc.

Things to consider:

  1. How do we test jekyll changes from mc? Do we have to keep the entire jekyll site here in order to achieve that.
  2. Do we need to add installation of Jekyll and associated tools alongside mach bootstrap to ensure that anyone is automatically set up to view locally, or just include instructions for those that need them.
  3. Do we handle user docuementation in a separate task to javadoc, or should they be lumped together under gv-docs.

Emily says she's working on this bug.

Assignee: nobody → etoop
Rank: 55
Priority: -- → P2

Examples are being moved to a new location and javadoc is already generated here and so these items are not being moved in this commit

Pushed by etoop@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/86ebbb20ef06
Move geckoview user documentation under mozilla-central. r=agi,nalexander,ahal
Pushed by etoop@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f53d1c154f7d
Move geckoview user documentation under mozilla-central. r=agi,nalexander,ahal
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

Only one of the 4 associated patches landed. Reopening until the rest land too.

Status: RESOLVED → REOPENED
Flags: needinfo?(etoop)
Resolution: FIXED → ---

Emily, the doc doesn't show on https://firefox-source-docs.mozilla.org/
Probably because this website expects rst while geckoview doc is using markdown.
Do you have plan to make this doc available in https://firefox-source-docs.mozilla.org/ too ?
thanks!

Flags: needinfo?(etoop)

We are currently using these docs to publish to the GV documentation site https://geckoview.dev (or at least will do once I get the r+ for the changes to the mach command). What would I have to do to these docs to make them also appear on https://firefox-source-docs.mozilla.org/ too? Or are the two formats (Jekyll for GH Pages and rst for firefox docs) too incompatible?

Flags: needinfo?(etoop) → needinfo?(sledru)

I created bug 1593218 to keep track of this work :)

Flags: needinfo?(sledru)

Setting firefox71=wontfix because we don't need to uplift these doc changes to Beta.

Pushed by etoop@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1f2c6dc5a14e
Update mach geckoview-docs command to upload markdown as well as javadoc. r=agi
https://hg.mozilla.org/integration/autoland/rev/c1e90bf96e14
Add messaging examples to Android Studio. r=agi
Attached file Bug 1585661 fix lint errors (obsolete) —
Attached file Bug 1585661 fix lint errors (obsolete) —
Attachment #9108686 - Attachment is obsolete: true
Attachment #9108675 - Attachment is obsolete: true
Pushed by etoop@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/126b37477819
Update mach geckoview-docs command to upload markdown as well as javadoc. r=agi
https://hg.mozilla.org/integration/autoland/rev/915910348bce
Add messaging examples to Android Studio. r=agi
Backout by malexandru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2fe825d522b2
Backed out 2 changesets for causing lint failures. CLOSED TREE
Pushed by etoop@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b7d60a096dae
Update mach geckoview-docs command to upload markdown as well as javadoc. r=agi
Status: REOPENED → RESOLVED
Closed: Last month21 days ago
Resolution: --- → FIXED
Regressions: 1597940
You need to log in before you can comment on or make changes to this bug.