Closed Bug 1585867 Opened 2 years ago Closed 2 years ago

Intermittent dom/tests/mochitest/localstorage/test_storageConstructor.html | application crashed [@ <name omitted>]

Categories

(Core :: JavaScript Engine, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1585874

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: crash, intermittent-failure, regression)

Crash Data

Filed by: dluca [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=269526650&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/LsSX8s2LRA-eODoEHCfPJw/runs/0/artifacts/public/logs/live_backing.log


  INFO -  859 INFO TEST-START | dom/tests/mochitest/localstorage/test_storageConstructor.html
[task 2019-10-02T22:28:15.484Z] 22:28:15     INFO -  860 INFO TEST-OK | dom/tests/mochitest/localstorage/test_storageConstructor.html | took 49ms
[task 2019-10-02T22:28:15.484Z] 22:28:15     INFO -  861 INFO TEST-START | Shutdown
[task 2019-10-02T22:28:15.484Z] 22:28:15     INFO -  862 INFO Passed:  92
[task 2019-10-02T22:28:15.484Z] 22:28:15     INFO -  863 INFO Failed:  0
[task 2019-10-02T22:28:15.485Z] 22:28:15     INFO -  864 INFO Todo:    0
[task 2019-10-02T22:28:15.485Z] 22:28:15     INFO -  865 INFO Mode:    e10s
[task 2019-10-02T22:28:15.485Z] 22:28:15     INFO -  866 INFO Slowest: 1103ms - /tests/dom/tests/mochitest/localstorage/test_brokenUTF-16.html
[task 2019-10-02T22:28:15.485Z] 22:28:15     INFO -  867 INFO SimpleTest FINISHED
[task 2019-10-02T22:28:15.485Z] 22:28:15     INFO -  wait for org.mozilla.geckoview.test complete; top activity=com.android.launcher3
[task 2019-10-02T22:28:15.588Z] 22:28:15     INFO -  remoteautomation.py | Application ran for: 0:00:12.866289
[task 2019-10-02T22:28:16.141Z] 22:28:16     INFO -  mozcrash Copy/paste: /builds/worker/workspace/build/linux64-minidump_stackwalk /tmp/tmpLfcXs0/4e9c57b0-9a15-75e3-9d59-db697326b437.dmp /builds/worker/workspace/build/symbols
[task 2019-10-02T22:28:20.162Z] 22:28:20     INFO -  mozcrash Saved minidump as /builds/worker/workspace/build/blobber_upload_dir/4e9c57b0-9a15-75e3-9d59-db697326b437.dmp
[task 2019-10-02T22:28:20.164Z] 22:28:20  WARNING -  PROCESS-CRASH | dom/tests/mochitest/localstorage/test_storageConstructor.html | application crashed [@ <name omitted>]
[task 2019-10-02T22:28:20.164Z] 22:28:20     INFO -  Crash dump filename: /tmp/tmpLfcXs0/4e9c57b0-9a15-75e3-9d59-db697326b437.dmp
[task 2019-10-02T22:28:20.164Z] 22:28:20     INFO -  Operating system: Android
[task 2019-10-02T22:28:20.164Z] 22:28:20     INFO -                    0.0.0 Linux 3.10.0+ #260 SMP PREEMPT Fri May 19 12:48:14 PDT 2017 x86_64
[task 2019-10-02T22:28:20.164Z] 22:28:20     INFO -  CPU: amd64
[task 2019-10-02T22:28:20.164Z] 22:28:20     INFO -       family 6 model 6 stepping 3
[task 2019-10-02T22:28:20.164Z] 22:28:20     INFO -       4 CPUs
[task 2019-10-02T22:28:20.164Z] 22:28:20     INFO -  GPU: UNKNOWN
[task 2019-10-02T22:28:20.164Z] 22:28:20     INFO -  Crash reason:  SIGSEGV /SEGV_MAPERR
[task 2019-10-02T22:28:20.164Z] 22:28:20     INFO -  Crash address: 0x10
[task 2019-10-02T22:28:20.164Z] 22:28:20     INFO -  Process uptime: not available
[task 2019-10-02T22:28:20.164Z] 22:28:20     INFO -  Thread 17 (crashed)
[task 2019-10-02T22:28:20.164Z] 22:28:20     INFO -   0  libxul.so!<name omitted> [Verifier.cpp:83b9448bbfafc3dcec439577045c0fd8cee83633 : 312 + 0x0]
[task 2019-10-02T22:28:20.165Z] 22:28:20     INFO -      rax = 0x0000000000000000   rdx = 0x0000000000026e01
[task 2019-10-02T22:28:20.165Z] 22:28:20     INFO -      rcx = 0x0000000000000001   rbx = 0x00002c9735566e20
[task 2019-10-02T22:28:20.165Z] 22:28:20     INFO -      rsi = 0x00002c9735540000   rdi = 0x00002c9735566e20
[task 2019-10-02T22:28:20.165Z] 22:28:20     INFO -      rbp = 0x00007062635020e0   rsp = 0x00007062635020e0
[task 2019-10-02T22:28:20.165Z] 22:28:20     INFO -       r8 = 0x00000000000016c2    r9 = 0x0000706263502450
[task 2019-10-02T22:28:20.165Z] 22:28:20     INFO -      r10 = 0x0000000000000000   r11 = 0x0000000000000246
[task 2019-10-02T22:28:20.165Z] 22:28:20     INFO -      r12 = 0x00007062615fb9b0   r13 = 0x0000000000000400
[task 2019-10-02T22:28:20.165Z] 22:28:20     INFO -      r14 = 0x0000706262beea40   r15 = 0x00007062615fa000
[task 2019-10-02T22:28:20.165Z] 22:28:20     INFO -      rip = 0x000070626d7da6bd
[task 2019-10-02T22:28:20.165Z] 22:28:20     INFO -      Found by: given as instruction pointer in context
[task 2019-10-02T22:28:20.165Z] 22:28:20     INFO -   1  libxul.so!js::gc::TenuredCell::writeBarrierPre(js::gc::TenuredCell*) [Cell.h:83b9448bbfafc3dcec439577045c0fd8cee83633 : 414 + 0x8]
[task 2019-10-02T22:28:20.165Z] 22:28:20     INFO -      rbp = 0x0000706263502110   rsp = 0x00007062635020f0
[task 2019-10-02T22:28:20.165Z] 22:28:20     INFO -      rip = 0x000070626ceeea58
[task 2019-10-02T22:28:20.165Z] 22:28:20     INFO -      Found by: previous frame's frame pointer
[task 2019-10-02T22:28:20.165Z] 22:28:20     INFO -   2  libxul.so!mozilla::HashMapEntry<js::HeapPtr<JSAtom*>, unsigned int>::~HashMapEntry() [HashTable.h:83b9448bbfafc3dcec439577045c0fd8cee83633 : 100 + 0x56]
[task 2019-10-02T22:28:20.165Z] 22:28:20     INFO -      rbp = 0x0000706263502140   rsp = 0x0000706263502120
[task 2019-10-02T22:28:20.166Z] 22:28:20     INFO -      rip = 0x000070626d4235d6
[task 2019-10-02T22:28:20.166Z] 22:28:20     INFO -      Found by: previous frame's frame pointer
[task 2019-10-02T22:28:20.166Z] 22:28:20     INFO -   3  libxul.so!js::XDRIncrementalEncoder::~XDRIncrementalEncoder() [Xdr.h:83b9448bbfafc3dcec439577045c0fd8cee83633 : 562 + 0x5f]
[task 2019-10-02T22:28:20.166Z] 22:28:20     INFO -      rbp = 0x0000706263502180   rsp = 0x0000706263502150
[task 2019-10-02T22:28:20.166Z] 22:28:20     INFO -      rip = 0x000070626d42328f
[task 2019-10-02T22:28:20.166Z] 22:28:20     INFO -      Found by: previous frame's frame pointer
[task 2019-10-02T22:28:20.166Z] 22:28:20     INFO -   4  libxul.so!js::ScriptSource::~ScriptSource() [JSScript.h:83b9448bbfafc3dcec439577045c0fd8cee83633 : 732 + 0x30]
[task 2019-10-02T22:28:20.166Z] 22:28:20     INFO -      rbp = 0x00007062635021b0   rsp = 0x0000706263502190
[task 2019-10-02T22:28:20.166Z] 22:28:20     INFO -      rip = 0x000070626d26e735
[task 2019-10-02T22:28:20.166Z] 22:28:20     INFO -      Found by: previous frame's frame pointer
[task 2019-10-02T22:28:20.166Z] 22:28:20     INFO -   5  libxul.so!js::SourceCompressionTask::~SourceCompressionTask() [HelperThreads.h:83b9448bbfafc3dcec439577045c0fd8cee83633 : 838 + 0x42]
[task 2019-10-02T22:28:20.166Z] 22:28:20     INFO -      rbp = 0x00007062635021e0   rsp = 0x00007062635021c0
[task 2019-10-02T22:28:20.166Z] 22:28:20     INFO -      rip = 0x000070626d26e211
[task 2019-10-02T22:28:20.166Z] 22:28:20     INFO -      Found by: previous frame's frame pointer
[task 2019-10-02T22:28:20.167Z] 22:28:20     INFO -   6  libxul.so!js::AttachFinishedCompressions(JSRuntime*, js::AutoLockHelperThreadState&) [HelperThreads.cpp:83b9448bbfafc3dcec439577045c0fd8cee83633 : 2459 + 0x9]
[task 2019-10-02T22:28:20.167Z] 22:28:20     INFO -      rbp = 0x0000706263502230   rsp = 0x00007062635021f0
[task 2019-10-02T22:28:20.167Z] 22:28:20     INFO -      rip = 0x000070626d124bc9
[task 2019-10-02T22:28:20.167Z] 22:28:20     INFO -      Found by: previous frame's frame pointer
[task 2019-10-02T22:28:20.167Z] 22:28:20     INFO -   7  libxul.so!SweepCompressionTasks(js::GCParallelTask*) [GC.cpp:83b9448bbfafc3dcec439577045c0fd8cee83633 : 5110 + 0x8]
[task 2019-10-02T22:28:20.167Z] 22:28:20     INFO -      rbp = 0x0000706263502290   rsp = 0x0000706263502240
[task 2019-10-02T22:28:20.167Z] 22:28:20     INFO -      rip = 0x000070626d73f3e9
[task 2019-10-02T22:28:20.167Z] 22:28:20     INFO -      Found by: previous frame's frame pointer
[task 2019-10-02T22:28:20.167Z] 22:28:20     INFO -   8  libxul.so!js::GCParallelTask::runFromHelperThread(js::AutoLockHelperThreadState&) [HelperThreads.cpp:83b9448bbfafc3dcec439577045c0fd8cee83633 : 1806 + 0x9]
[task 2019-10-02T22:28:20.167Z] 22:28:20     INFO -      rbp = 0x00007062635022d0   rsp = 0x00007062635022a0
[task 2019-10-02T22:28:20.167Z] 22:28:20     INFO -      rip = 0x000070626d120007
[task 2019-10-02T22:28:20.167Z] 22:28:20     INFO -      Found by: previous frame's frame pointer
[task 2019-10-02T22:28:20.167Z] 22:28:20     INFO -   9  libxul.so!js::HelperThread::handleGCParallelWorkload(js::AutoLockHelperThreadState&) [HelperThreads.cpp:83b9448bbfafc3dcec439577045c0fd8cee83633 : 1827 + 0xb]
[task 2019-10-02T22:28:20.167Z] 22:28:20     INFO -      rbp = 0x0000706263502340   rsp = 0x00007062635022e0
[task 2019-10-02T22:28:20.168Z] 22:28:20     INFO -      rip = 0x000070626d1204cd
[task 2019-10-02T22:28:20.168Z] 22:28:20     INFO -      Found by: previous frame's frame pointer
[task 2019-10-02T22:28:20.168Z] 22:28:20     INFO -  10  libxul.so!js::HelperThread::threadLoop() [HelperThreads.cpp:83b9448bbfafc3dcec439577045c0fd8cee83633 : 2628 + 0x1c]
[task 2019-10-02T22:28:20.168Z] 22:28:20     INFO -      rbp = 0x00007062635023b0   rsp = 0x0000706263502350
[task 2019-10-02T22:28:20.168Z] 22:28:20     INFO -      rip = 0x000070626d12245f
[task 2019-10-02T22:28:20.168Z] 22:28:20     INFO -      Found by: previous frame's frame pointer
[task 2019-10-02T22:28:20.168Z] 22:28:20     INFO -  11  libxul.so!js::detail::ThreadTrampoline<void (&)(void*), js::HelperThread*>::Start(void*) [Thread.h:83b9448bbfafc3dcec439577045c0fd8cee83633 : 199 + 0x1a]
[task 2019-10-02T22:28:20.168Z] 22:28:20     INFO -      rbp = 0x00007062635023e0   rsp = 0x00007062635023c0
[task 2019-10-02T22:28:20.168Z] 22:28:20     INFO -      rip = 0x000070626d14fda5
[task 2019-10-02T22:28:20.168Z] 22:28:20     INFO -      Found by: previous frame's frame pointer
[task 2019-10-02T22:28:20.168Z] 22:28:20     INFO -  12  libc.so + 0x89772
[task 2019-10-02T22:28:20.168Z] 22:28:20     INFO -      rsp = 0x00007062635023f0   rip = 0x000070628c962772
[task 2019-10-02T22:28:20.168Z] 22:28:20     INFO -      Found by: stack scanning
[task 2019-10-02T22:28:20.168Z] 22:28:20     INFO -  13  libxul.so + 0x45ded70
[task 2019-10-02T22:28:20.168Z] 22:28:20     INFO -      rsp = 0x0000706263502428   rip = 0x000070626d14fd70
[task 2019-10-02T22:28:20.168Z] 22:28:20     INFO -      Found by: stack scanning
[task 2019-10-02T22:28:20.169Z] 22:28:20     INFO -  14  libc.so + 0x299ec
[task 2019-10-02T22:28:20.169Z] 22:28:20     INFO -      rsp = 0x0000706263502440   rip = 0x000070628c9029ec
[task 2019-10-02T22:28:20.169Z] 22:28:20     INFO -      Found by: stack scanning
[task 2019-10-02T22:28:20.169Z] 22:28:20     INFO -  15  libc.so + 0x896c0
[task 2019-10-02T22:28:20.169Z] 22:28:20     INFO -      rsp = 0x0000706263502448   rip = 0x000070628c9626c0
[task 2019-10-02T22:28:20.169Z] 22:28:20     INFO -      Found by: stack scanning
[task 2019-10-02T22:28:20.169Z] 22:28:20     INFO -  16  libc.so + 0x1ca66
[task 2019-10-02T22:28:20.169Z] 22:28:20     INFO -      rsp = 0x0000706263502450   rip = 0x000070628c8f5a66
[task 2019-10-02T22:28:20.169Z] 22:28:20     INFO -      Found by: stack scanning
[task 2019-10-02T22:28:20.169Z] 22:28:20     INFO -  17  libxul.so + 0x45ded70
[task 2019-10-02T22:28:20.169Z] 22:28:20     INFO -      rsp = 0x00007062635024b8   rip = 0x000070626d14fd70
[task 2019-10-02T22:28:20.169Z] 22:28:20     INFO -      Found by: stack scanning
[task 2019-10-02T22:28:20.169Z] 22:28:20     INFO -  Thread 0
See Also: → 1585874
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 2 years ago
Component: DOM: Web Storage → JavaScript Engine
Resolution: --- → DUPLICATE
Duplicate of bug: 1585874
You need to log in before you can comment on or make changes to this bug.