Non-"standard" characters in file paths are not displayed correctly in mail prefs

VERIFIED DUPLICATE of bug 66868

Status

--
minor
VERIFIED DUPLICATE of bug 66868
16 years ago
10 years ago

People

(Reporter: jpmelko, Assigned: nhottanscp)

Tracking

({intl})

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.1b) Gecko/20020721
BuildID:    2002072103

Using some characters in the profile pathes cause a bad display in the mail prefs
i have created a profile inside a folder named "titi ƒ" (titi%20%C4)
and then created accounts (mail and news)
Server setting show a wrong character in place of C4
so it seems impossible to edit. Entering a C4 character broke the path and an
other folder is created. The C4 is replaced on the desktop by a ì

Reproducible: Always
Steps to Reproduce:
1.Create a folder with a C4 character
2.Create a new profile inside it
3.Create accounts
4. Open mail prefs and look at "server settings"

Actual Results:  bad display of the character in newsrc file and local directory

Expected Results:  Correct display (the good character or %C4)

I have submitted bug 158163, about special charater handling in save menus. May
be that the cause is the same.

There is some incoherence in path handling in Mozilla
My home page is also in these folder. I see titi%20%C4
My signature file path is correct, i see the correct path.(with out % translation)
I suspect that the browser use %xx, and not the mail.

Comment 1

16 years ago
Confirmed using Mac/2002080208/9.2.2. I created a folder with a lowercase letter i with acute 
accent as its' name. I then created a Mozilla profile inside it and configured one newsgroup 
account. The accented letter was not displayed correctly in either the newsrc file path nor the 
Local directory path. (Screenshot to be attached.)

The letter should either be displayed correctly or as a %-encoded hex number, preferably the 
former.

Reassigning to Internationalization.
Assignee: sspitzer → nhotta
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → Internationalization
Ever confirmed: true
QA Contact: olgam → marina
Summary: non "standard" characters in file pathes are not displayed correctely in mail prefs → Non-"standard" characters in file paths are not displayed correctly in mail prefs

Comment 2

16 years ago
Created attachment 93951 [details]
Screenshot of Mac/2002080208/9.2.2 showing bad representation of folder on desktop in newsrc and local directory path

Updated

16 years ago
Keywords: intl
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED

Comment 3

16 years ago
dup of bug # 55582?
(Assignee)

Comment 4

16 years ago
dup of bug 66868

*** This bug has been marked as a duplicate of 66868 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
verified as such
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.