Closed Bug 1585919 Opened 6 months ago Closed 5 months ago

Megabar should stay collapsed after window drag on Linux

Categories

(Firefox :: Address Bar, defect, P3)

Unspecified
Linux
defect
Points:
3

Tracking

()

RESOLVED INVALID
Tracking Status
firefox71 --- affected

People

(Reporter: bj, Unassigned)

References

(Blocks 1 open bug)

Details

The effect on megabar for move window, resize window, and minimize/maximize should be consistent.

When the address bar is expanded and the window is resized or dragged the size is reduced during the operation and restored to the expanded size as soon as the operation is complete.

This doesn't happen when the window Maximize or Minimize button is clicked. The address bar is set to non-expanded by the operation. Focus is still in the address bar and using arrow keys moves focus around in the address bar, typing a character causes the bar to expand.

Using XFCE on Ubuntu.

The maximize/minimize behaviour is the correct behaviour. It's the drag behaviour you're describing that's the problem here. The Megabar is supposed to collapse but stay focused when any part of the browser UI is clicked. It should not expand until the user interacts directly with the Urlbar, such as by clicking or typing in it. This includes window drags; the Megabar should collapse at dragstart and stay collapsed after the drag is complete.

I can't replicate this issue on Mac, but I can on Linux. Windows has more problems with the Focused & Collapsed state (bug 1586024) that need to be resolved first before seeing if this is an issue on Windows too.

Summary: Megabar should return to expanded size after clicking the window maximize/minimize buttons → Megabar should stay collapsed after window drag on Linux

The cause for this is platform-specific drag behaviour. On Mac, if the Urlbar is focused and the window is dragged the Urlbar stays focused the whole time during the drag. On Linux, we blur the bar during the drag and then refocus it after the drag. The refocus event triggers Megabar expansion. I don't know how we handle this on Windows.

Priority: -- → P3
Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 71.4 - Oct 14 - 20
Points: --- → 3

Unassigning myself as we wait for Verdi's design revision. The design tweaks may make this irrelevant.

Assignee: htwyford → nobody
Status: ASSIGNED → NEW
Iteration: 71.4 - Oct 14 - 20 → ---
Depends on: 1589826

Bug 1589826 removes the Focused & Collapsed state, which means this is no longer an issue. The megabar will always be expanded when it is focused.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.