Closed Bug 1586048 Opened 2 months ago Closed 2 months ago

Closing Devtools with an active breakpoint on a `debugger` keyword prevents following statements from running

Categories

(DevTools :: Debugger, defect, P2)

69 Branch
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1571637

People

(Reporter: vitorveiga.eeic, Unassigned)

References

(Blocks 2 open bugs)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.90 Safari/537.36

Steps to reproduce:

  1. Run the following snippet in console

function run() {debugger; setTimeout(run, 1000); alert('LIVE');}
run();

  1. A breakpoint on debugger keyword should be activated
  2. Finnaly, close devtools

Actual results:

Alert message is not displayed

Expected results:

Should receive an alert with 'LIVE' message

Summary: Closing Devtools with an active breakpoint on a `debugger` keyword prevents following statement from running → Closing Devtools with an active breakpoint on a `debugger` keyword prevents following statements from running

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Debugger
Product: Firefox → DevTools

Thanks for the report!

I can reproduce this on my machine (Win10)

Honza

Status: UNCONFIRMED → NEW
Has STR: --- → yes
Ever confirmed: true
Priority: -- → P2

Jason, could you please look at this one?
Thanks,
Honza

Flags: needinfo?(jlaster)
Flags: needinfo?(jlaster)
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1571637
You need to log in before you can comment on or make changes to this bug.