Closed Bug 1586111 Opened 5 months ago Closed 5 months ago

Update-Verify fails on Thunderbird beta: ACCEPTED_MAR_CHANNEL_ID

Categories

(Thunderbird :: Build Config, defect)

defect
Not set

Tracking

(thunderbird70 fixed, thunderbird71 fixed)

RESOLVED FIXED
Thunderbird 71.0
Tracking Status
thunderbird70 --- fixed
thunderbird71 --- fixed

People

(Reporter: rjl, Assigned: rjl)

Details

Attachments

(1 file)

This consistently occurs on beta releases. It's a configuration problem.

Difference found in update-settings.ini
update-settings.ini still differs after transforms, residual diff:
-ACCEPTED_MAR_CHANNEL_IDS=thunderbird-comm-beta,thunderbird-comm-release
+ACCEPTED_MAR_CHANNEL_IDS=thunderbird-comm-beta
TEST-UNEXPECTED-FAIL: differences found after update
TEST-UNEXPECTED-FAIL: [69.0 de complete] check_updates returned failure for Linux_x86_64-gcc3 downloads/thunderbird-69.0b3.tar.bz2 vs. downloads/thunderbird-70.0b3.tar.bz2: 1

The fix needs to go in comm/taskcluster/ci/build/kind.yml. Add "thunderbird-comm-release" to "accepted-mar-channel-ids" for release-type "beta". Firefox has their configured that way.

Fixes a long standing bug on beta releases with Update Verify tests.
The updated string finds its way to a step that looks at the results of
a directory diff. update-settings.ini does have both -beta and -release
in it, so verification fails because it's only expecting -beta.
Attachment #9099063 - Flags: review?(geoff)
Assignee: nobody → rob
Status: NEW → ASSIGNED
Attachment #9099063 - Flags: review?(geoff) → review+
Keywords: checkin-needed

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/d5a91d48099b
Update-verify test fix for beta builds. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

Uplift to beta, right?

Target Milestone: --- → Thunderbird 71.0
Comment on attachment 9099063 [details] [diff] [review]
bug_1586111.patch

[Approval Request Comment]
Regression caused by (bug #): unknown,
User impact if declined: none
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky):
There is no end-user impact if this doesn't work out for any reason. The fix only affects how the differences between two install directories are processed.
Attachment #9099063 - Flags: approval-comm-beta?
Comment on attachment 9099063 [details] [diff] [review]
bug_1586111.patch

In general, you don't need to fill in the approval request details ;-)
Attachment #9099063 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.