Newline character after PI not serialized.

RESOLVED DUPLICATE of bug 158617

Status

()

Core
XML
RESOLVED DUPLICATE of bug 158617
16 years ago
16 years ago

People

(Reporter: Sivakiran Tummala, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
mozilla1.2alpha
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
BuildID:    2002-07-17-08-01


The string returned by the serializer looks something like this:
<?xml-stylesheet href="display.css" type="text/css"?><!DOCTYPE doc [

There should be a newline after the PI (<?...?>) and <!DOCTYPE

Reproducible: Always

The URL has the testcase.

Comment 1

16 years ago
Note that a XML declaration is not a PI. Does this happen for PIs too, or only
XML declarations?
We don't serialize XML declarations yet.
(Reporter)

Comment 3

16 years ago
it happens to PI's too, not XML declarations.

Updated

16 years ago
QA Contact: petersen → rakeshmishra
Keywords: nsbeta1+
Target Milestone: --- → mozilla1.2alpha
Found the cause, have fix, and this is in fact a dupe 158617.

*** This bug has been marked as a duplicate of 158617 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.