Closed Bug 1586164 Opened 2 years ago Closed 2 years ago

Background color of tab bar broken with default theme

Categories

(Core :: Graphics: WebRender, defect)

71 Branch
x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1585898
Tracking Status
firefox71 --- affected

People

(Reporter: irvin, Unassigned)

Details

Attachments

(3 files, 1 obsolete file)

The background color of Tab bar turned white after 10/2 updating, text not visible, will return to normal when and only when website opening in new tab, will return broken after website loaded.

It only happens in the default theme.

Please check the video, https://youtu.be/RaStSkreV4c

Summary: Background color of tab bar randomly break with default theme → Background color of tab bar broken with default theme

The second video, https://youtu.be/nbKElZNkyY0

  • Only resumes to normal during web loading. After page ready, it return to white.
  • And it will always resume normally when system page (setting, addon... etc) is in the foreground.
  • When focus to the URL bar, it seems to be much larger and the dropdown menu also seems weird.
  • Turn off hardware acceleration fix tab bar background

Turn off hardware acceleration fix tab bar background, but URL teme still weird

Attached image weired bigger awesome bar (obsolete) —

bg color resume to normal for a short time, while loading website in a new tab (open website in current tab won't work)

  • Disable all addon don't help.
  • Can't represent issue in new profile. (new profile work normally)
  • Work normal in safe mode
  • Broken after "restart with addon disabled"
  • Refresh Firefox fix issue (even normal after resume all 480 tabs)

"Enlarged location bar on focus" problem occurs on both of my Windows 10 PCs, but not the others.

(In reply to Selim Şumlu from comment #9)

"Enlarged location bar on focus" problem occurs on both of my Windows 10 PCs, but not the others.

It turns out the "megabar" (bug 1561531) is a feature that hasn't recieved much love so far, but it's not a bug.

Component: Theme → Graphics: WebRender
Product: Firefox → Core
Attachment #9098722 - Attachment is obsolete: true
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1585898
You need to log in before you can comment on or make changes to this bug.