Closed Bug 1586188 Opened 2 months ago Closed 2 months ago

Import WebCompat GoFaster 6.2.0 sources

Categories

(Web Compatibility :: Interventions, task)

task
Not set

Tracking

(relnote-firefox 69+, firefox-esr68 fixed, firefox69 fixed, firefox70+ fixed, firefox71+ fixed)

RESOLVED FIXED
Tracking Status
relnote-firefox --- 69+
firefox-esr68 --- fixed
firefox69 --- fixed
firefox70 + fixed
firefox71 + fixed

People

(Reporter: ksenia, Assigned: ksenia)

References

Details

Attachments

(1 file)

No description provided.
Pushed by mitaylor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/46107419671f
Import WebCompat GoFaster 6.2.0 sources; r=miketaylr

[Tracking Requested - why for this release]: This fixes 3 important site compat bugs:

https://bugzilla.mozilla.org/show_bug.cgi?id=1582848 (download dialog for some yahoo mail users)
https://bugzilla.mozilla.org/show_bug.cgi?id=1582582 (sling.com UA override)
https://bugzilla.mozilla.org/show_bug.cgi?id=1580607 (download dialog when logging out of office365)

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Comment on attachment 9098750 [details]
Bug 1586188 - Import WebCompat GoFaster 6.2.0 sources; r=denschub, miketaylr

Beta/Release Uplift Approval Request

  • User impact if declined: We'd like to get this into 70, if possible.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): These are scoped to specific domains.
  • String changes made/needed:
Attachment #9098750 - Flags: approval-mozilla-beta?

Comment on attachment 9098750 [details]
Bug 1586188 - Import WebCompat GoFaster 6.2.0 sources; r=denschub, miketaylr

Webcompat fixes for 70, OK to uplift for beta 13.

Attachment #9098750 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Blocks: 1587186
No longer blocks: 1587186
Depends on: 1587186

Comment on attachment 9098750 [details]
Bug 1586188 - Import WebCompat GoFaster 6.2.0 sources; r=denschub, miketaylr

Beta/Release Uplift Approval Request

  • User impact if declined: Users can get a download prompt when checking their email or using office365.

See https://bugzilla.mozilla.org/show_bug.cgi?id=1583366#c4 and https://bugzilla.mozilla.org/show_bug.cgi?id=1582848

  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): We've been shipping in Nightly (4 days) and Beta (3 days) without users complaining of regressions or related bustage.
  • String changes made/needed:
Attachment #9098750 - Flags: approval-mozilla-release?

Ryan, putting this on your dot release radar -- ideally Bug 1587186 would get resolved first (so we don't overwrite this version from Balrog, because it is cool with overwriting older versions).

Flags: needinfo?(ryanvm)

Comment on attachment 9098750 [details]
Bug 1586188 - Import WebCompat GoFaster 6.2.0 sources; r=denschub, miketaylr

(This should ship to ESR Desktop folks as well)

Attachment #9098750 - Flags: approval-mozilla-esr68?

Comment on attachment 9098750 [details]
Bug 1586188 - Import WebCompat GoFaster 6.2.0 sources; r=denschub, miketaylr

Fixes some compatibility issues with large sites. Approved for 69.0.3 and 68.2esr.

Flags: needinfo?(ryanvm)
Attachment #9098750 - Flags: approval-mozilla-release?
Attachment #9098750 - Flags: approval-mozilla-release+
Attachment #9098750 - Flags: approval-mozilla-esr68?
Attachment #9098750 - Flags: approval-mozilla-esr68+

Added to the 69.0.3 relnotes:

Fixed Yahoo mail users being prompted to download files when clicking on emails

You need to log in before you can comment on or make changes to this bug.