Closed Bug 1586262 Opened 4 months ago Closed 3 months ago

run-task may not log the entire contents of a long line of task output

Categories

(Firefox Build System :: Task Configuration, task, P1)

Tracking

(firefox71 fixed)

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: gbrown, Assigned: gbrown)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

run-task does not check the return value of write() at:

https://searchfox.org/mozilla-central/rev/01d1011ca4a460f751da030d455d35c267c3e210/taskcluster/scripts/run-task#106

If less than the full requested buffer is written, the remainder is discarded.

I suspect this is the cause of bug 1567638.

https://treeherder.mozilla.org/#/jobs?repo=try&tier=1%2C2%2C3&revision=80d561d084611e5db5768f26236e11869386e68f

demonstrates the issue by writing very long (20000 character) lines of output from the task: write() often reports writing less than requested, and the effect is evident in the log output.

Check the return code of write() to determine if the output line has actually
been written completely; if not, write the remainder.

Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bcfc1146667c
Ensure run-task logs very long task output lines; r=dustin
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
You need to log in before you can comment on or make changes to this bug.