Closed Bug 1586378 Opened 3 years ago Closed 3 years ago

[Mac] Nothing is being imported from Safari

Categories

(Firefox :: Migration, defect, P2)

All
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1493103
Tracking Status
firefox69 --- affected
firefox70 --- affected
firefox71 --- affected

People

(Reporter: bugzilla, Unassigned)

Details

+++ This bug was initially created as a clone of Bug #1236916 +++

Per comments 7-11 in Bug 1236916, the Safari importer has ceased to work. It no longer imports anything, including History, Bookmarks, and Other Data. I tested this on Nightly 71.0a1 (2019-10-03) and Release 69.0.2. The Safari importer displays a success message, but it actually fails.

The console prints

JavaScript error: resource://gre/modules/PropertyListUtils.jsm, line 159: Error: aBuffer cannot be parsed as a DOM document: Error: aDoc is not a property list document

when the success message is displayed.

It's possible that just as Safari History moved to a Sqlite DB from a plist in Safari 8 (bug 1236916 comment 5), Bookmarks moved to Sqlite in the time since Safari 8.

It'd be great if this can be fixed soon. If not, I propose disabling the Safari importer until we can fix this.

What version of macOS and Safari?

Flags: needinfo?(htwyford)

macOS 10.14.5, Safari 12.1.1 (14607.2.6.1.1).

Flags: needinfo?(htwyford)

/Users/[username]/Library/Safari/Bookmarks.plist still exists, so it's not a Sqlite thing.

I can reproduce on 10.14. Digging into this a bit, we get a security error trying to load Bookmarks.plist from the Safari library directory.

In fact, even from terminal, trying to touch files in that directory fails with errors, and https://unix.stackexchange.com/questions/472576/macos-mojave-directory-permissions suggests this is a new security measure in 10.14 and later where access to Safari/Mail.app files from other apps is not possible unless you grant those applications "full disk access". It doesn't seem there's a good way to ask for that access...

I expect we should disable the Safari importer on macOS 10.14 and later using AppConstants.isPlatformAndVersionAtLeast

(That or we can check, if the bookmarks.plist file exists, if we actually have read access to it...)

Looks like Chrome's Safari importer is broken too.

Per discussion in Slack, I'm needinfoing haik, who has offered to look for a workaround.

If we can't get anything to work, it might be worth reaching out to Apple to see if they can offer us an exception only on these Bookmarks/History files?

Flags: needinfo?(haftandilian)

The path is already clear, this just hasn’t been prioritized by product.

Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(haftandilian)
Resolution: --- → DUPLICATE
No longer blocks: 1236916
You need to log in before you can comment on or make changes to this bug.