Closed Bug 1586659 Opened 2 months ago Closed 2 months ago

[Protections Panel] Anchor arrow is purple when it's on the bottom

Categories

(Firefox :: Site Identity, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox70 --- verified
firefox71 --- verified

People

(Reporter: nhnt11, Assigned: nhnt11)

References

(Blocks 1 open bug)

Details

(Whiteboard: [privacy-panel][skyline])

Attachments

(1 file)

STR:

Move Firefox to the very bottom of the screen and open the panel - it will open above the URL bar rather than below.

In this case, we shouldn't be coloring the arrow purple.

Fortunately this is a cheap fix, but there's a similar issue when Firefox is all the way at the inline-end side of the screen - we should swap the LTR and RTL colors in that case because the arrow gets pushed to the other side. But I don't know how to do this without manually calculating available space and inferring that we need to. There doesn't seem to be an attribute or anything.

Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ff84a91c8641
[Protections Panel] Only color the anchor arrow when it's at the top. r=johannh
Priority: -- → P1
Priority: P1 → P3
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Comment on attachment 9099136 [details]
Bug 1586659 - [Protections Panel] Only color the anchor arrow when it's at the top. r=timhuang,johannh

Beta/Release Uplift Approval Request

  • User impact if declined: Small visual anomaly when Firefox is in the bottom half of the screen - the panel arrow is purple even though it's not part of the header.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Move Firefox towards the bottom of the screen, and open the protections panel - it will open above Firefox due to lack of space below. Without the patch, the arrow of the panel is purple. With the patch, it matches the panel's color.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Visual polish. Extremely simple CSS change.
  • String changes made/needed:
Attachment #9099136 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Build ID 20191007215350
User Agent Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

Verified as fixed on the latest Nightly build on Windows 7.

Comment on attachment 9099136 [details]
Bug 1586659 - [Protections Panel] Only color the anchor arrow when it's at the top. r=timhuang,johannh

Minor polish issue, css only, OK for beta 14 uplift.

Attachment #9099136 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Build ID 20191010142853
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Verified as fixed on the latest Beta build (70.0b14) on Windows 10.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.