Closed Bug 1586660 Opened 3 years ago Closed 3 years ago

link with fragment does not open to that fragment

Categories

(Core :: Layout, defect)

60 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1305957

People

(Reporter: mjkaelbling, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:60.0) Gecko/20100101 Firefox/60.0

Steps to reproduce:

paste & go to: https://boyter.org/posts/an-informal-survey-of-10-million-github-bitbucket-gitlab-projects/#which-language-developers-have-the-biggest-potty-mouth

Actual results:

Opened to the bottom of the page

Expected results:

Open to the heading with ID='which-language-developers-have-the-biggest-potty-mouth'

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0
20191001234643

Works for me.

Has STR: --- → yes
Component: Untriaged → Layout
Product: Firefox → Core

Works here too. This was reported on Firefox 60, is there any chance you could test at least the next ESR (Firefox 68?)

(In reply to Emilio Cobos Álvarez (:emilio) from comment #2)

Works here too. This was reported on Firefox 60, is there any chance you could test at least the next ESR (Firefox 68?)

Sorry, I cannot test on Firefox 68 due to my corporately managed set-up.

Ok, just tested locally in 60 and I could repro. The page is adding a bunch of content to the top on load, so what happens is that we scroll to the section, and then the content moves.

This was fixed by scroll anchoring, which is bug 1305957, and should be on the next ESR (it works on 68).

I don't think we'll uplift that work to ESR60 at this point unfortunately, so updating to the next ESR is what would fix it for you. The website could also fix it, by injecting its content earlier (it's a bid of bad authoring in this case).

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1305957
You need to log in before you can comment on or make changes to this bug.