Closed Bug 1586667 Opened 1 year ago Closed 1 year ago

NetMonitor blocking - uppercase text on first letter for tooltip text from status column on blocked requests

Categories

(DevTools :: Netmonitor, enhancement, P3)

enhancement

Tracking

(firefox70 wontfix, firefox71 wontfix, firefox72 verified)

VERIFIED FIXED
Firefox 72
Tracking Status
firefox70 --- wontfix
firefox71 --- wontfix
firefox72 --- verified

People

(Reporter: cfogel, Assigned: davidwalsh)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Affected versions

  • 70.0b11, 71.0a1 (2019-10-06);
  • 69.0.2, 68.1.0esr - does not even have the tooltip message displayed yet;

Affected platforms

  • all available;

Steps to reproduce

  1. Enable/access DevTools -> Network tab -> Request blocking section;
  2. Add some filters/ block requests;
  3. Refresh the page;
  4. Hover over the icon from the Status column for the blocked request;

Expected result

  • tooltip with information text text is displayed;

Actual result

  • text displayed is "blocked"

Enhancement suggestion

  1. text displayed is "Blocked" ;
  2. text displayed is "Blocked by DevTools" as per Transferred cell information;

Regression range

  • not a regression;

Additional notes

  • attached screenshot with the issue;

  • since the tooltips are currently limited to the nightly(71) builds, marking only 71 builds as affected, but RC(60.0.x) ones would benefit of this as well once

  • @Honza, posting bellow current status for others as well since the 200 - OK one could also be revised and have a similar format such as "Ok"
    Other requests status:

  • 200 - 200 OK (cached)

  • 404 - 404 Not Found

  1. text displayed is "Blocked" ;
  2. text displayed is "Blocked by DevTools" as per Transferred cell information;

If we already show "Blocked by DevTools" in the same table row I wouldn't repeat it as alt text of the image (wouldn't be ideal for accessibility), but as a title it might be fine.

Something like:

<div class="Blocked by DevTools">
  <img alt="Blocked" ...>
</div>

where "Blocked" is always the same and "Blocked by DevTools" is the detailed reason.

Related: in bug 1586537 I'm suggesting moving that icon to the "Domain" column. (Don't know if we're going to do it yet.)

Thanks for the report!

(In reply to Cristian Fogel, QA [:cfogel] from comment #0)

Expected result

  • tooltip with information text text is displayed;

Not sure if I understand this. What are you referring to by text text?

  • @Honza, posting bellow current status for others as well since the 200 - OK one could also be revised and have a similar format such as "Ok"
    Other requests status:
  • 200 - 200 OK (cached)
  • 404 - 404 Not Found

Why we should repeat the number twice in the tooltip? Isn't 200 OK enough (also given that the user is hovering over the status number)? Or am I missing something?

Honza

Flags: needinfo?(florens)

Redirecting the needinfo to Cristian, I think the questions were for them.

Flags: needinfo?(florens) → needinfo?(cristian.fogel)

Yes, thanks for this.

(In reply to Jan Honza Odvarko [:Honza] (always need-info? me) from comment #2)

Not sure if I understand this. What are you referring to by text text?

This is an unfortunate rephrase correction that went unnoticed.
"Tooltip with formatted text is displayed" would make more sense.

Why we should repeat the number twice in the tooltip? Isn't 200 OK enough (also given that the user is hovering over the status number)? Or am I missing something?

It is, probably adding them as examples caused more confusion that intended.
My thoughts where that for 200, on hover currently shows 200 OK. It could display 200 Ok instead and have the same formatting as for the 404 one which shows the text with both upper and lower cased text.

Flags: needinfo?(cristian.fogel)

"OK" should probably be kept all uppercase because it's an initialism (like QA, BBC, etc.).
https://www.lexico.com/en/definition/ok
See also in the context of HTTP:
https://en.wikipedia.org/wiki/List_of_HTTP_status_codes#2xx_Success

Agreed. Disregard that part of the report then.

Assignee: nobody → dwalsh
Status: NEW → ASSIGNED
Pushed by dwalsh@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9b25bbff2835
Update case for blocked icon tooltip r=Honza
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

Confirmed fix with 72.0a1 (2019-11-13).

Updating status.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.