editor doesn't consume (preventdefault) on characters typed in

RESOLVED FIXED in mozilla1.2alpha

Status

()

RESOLVED FIXED
17 years ago
16 years ago

People

(Reporter: Brade, Assigned: Brade)

Tracking

Trunk
mozilla1.2alpha
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

17 years ago
While investigating a problem with Chimera, I found that the editor code
(nsPlaintextEditor.cpp) doesn't preventDefault for regular characters/letters
being typed.  I think this is a bug (right now, we only seem to prevent default
for delete/backspace, tab and return/enter).
(Assignee)

Comment 1

17 years ago
Created attachment 92225 [details] [diff] [review]
patch to be tested

This patch needs to be tested against many things to be sure there are no
regressions; any suggestions for regression testing?
(Assignee)

Comment 2

17 years ago
-->brade
Assignee: kin → brade
(Assignee)

Comment 3

17 years ago
Akkana--can you review this?
Status: NEW → ASSIGNED

Comment 4

17 years ago
Comment on attachment 92225 [details] [diff] [review]
patch to be tested

r=akkana
Attachment #92225 - Flags: review+

Comment 5

17 years ago
Comment on attachment 92225 [details] [diff] [review]
patch to be tested

sr=sfraser, but be sure to test this thoroughly, including IME etc.
Attachment #92225 - Flags: superreview+

Comment 6

17 years ago
I tested the patch on Windows2K using the testcase attached to bug 26882 and
it prevents spacebar from causing the pagedown behavior.
(Assignee)

Comment 7

16 years ago
fix checked into 1.2 trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.2alpha
(Assignee)

Comment 8

16 years ago
fix checked into the 1.0 branch
(Assignee)

Comment 9

16 years ago
reopening bug since this patch didn't address html editors
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

16 years ago
Created attachment 99557 [details] [diff] [review]
patch for html editors

Comment 11

16 years ago
Comment on attachment 99557 [details] [diff] [review]
patch for html editors

sr=sfraser
Attachment #99557 - Flags: superreview+

Comment 12

16 years ago
Comment on attachment 99557 [details] [diff] [review]
patch for html editors

brade says that the other events are PreventDefault'd in
nsEditorEventListener.cpp

i wouldn't mind a comment to that effect, but r=timeless either way
Attachment #99557 - Flags: review+
(Assignee)

Comment 13

16 years ago
fix checked in
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.