Closed Bug 1586880 Opened 2 months ago Closed Last month

New Request pane header should match the table header height and stay fixed

Categories

(DevTools :: Netmonitor, defect, P3)

defect

Tracking

(firefox72 fixed)

RESOLVED FIXED
Firefox 72
Tracking Status
firefox72 --- fixed

People

(Reporter: fvsch, Assigned: mustafa.abdelmogoud, Mentored)

Details

(Keywords: good-first-bug)

Attachments

(2 files)

Steps to reproduce:

  1. Open https://example.com/
  2. Open DevTools (F12), docked to the bottom, and give it a small height (e.g. around 300px).
  3. Go to Network and reload the page.
  4. Select the first request and, in the Headers pane in the sidebar, click "Edit and Resend"
  5. Scroll the "New Request" pane

Expected results:

  • The "New Request" header's height should match the request list's table headers height.
  • When scrolling, the "New Request" header should stay in place.

Actual results:

  • The header is 1px short (probably because we fixed the table header height, changing it from 24px to 25px).
  • The header scrolls away with the rest of the form when scrolling down, and disappears.

The scrolling issue is probably because we're not using overflow: auto on the correct element.

The header height is due to bug 1512513 landing. We can fix the header height using height: calc(var(--theme-toolbar-height) + 1px);.

Thanks for the report Florens!
Honza

Keywords: good-first-bug
Priority: -- → P3
Assignee: nobody → mustafa.abdelmogoud
Mentor: florens
Status: NEW → ASSIGNED
Pushed by florens@fvsch.com:
https://hg.mozilla.org/integration/autoland/rev/a670c36d436e
fix custom request header hight and scroll bug, r=fvsch
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
You need to log in before you can comment on or make changes to this bug.