Closed Bug 1586983 Opened 8 months ago Closed 5 months ago

Create a Mobile Client for Pontoon

Categories

(Webtools :: Pontoon, enhancement, P5)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1243132

People

(Reporter: ranjithraj, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0

Steps to reproduce:

Our community is doing great work in localizing the strings of pontoon.mozilla.org to Indian languages.

Actual results:

Web-only version is limiting the contribution levels as many don't own a laptop or can't carry their personal systems to places.

Expected results:

Pontoon Mobile Client would increase the accessibility to pontoon.mozilla.org which will ease the work of translators who can translate strings wherever they want as they carry their mobile phone.

Thanks for the report, Ranjith! I agree this is a very important topic and it needs to be addressed.

Note that bug 1243132 might be related to that - it's about making the translate page responsive and as such useful on a mobile device. So my question is - do you necessary need want a native mobile client (i.e. and Android and iOS app), or do you think a responsive web app would be sufficient (we can develop that much faster)?

To help you with the answer, think about your use case - do you want all core functionalities of Pontoon to be accessbile on mobile (translation, review, access to dashbaords) or are you mostly interested in one or two of them (e.g. review only)?

Ranjith, could you please answer the above questions?

Flags: needinfo?(ranjithraj)
Priority: -- → P5

I'm sorry for delay in the reply.

A responsive web app would suffice the current need. Translation and review are priority features, others can be accessed from desktop version.

Flags: needinfo?(ranjithraj)

Thanks! Marking as dupe.

Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1243132
You need to log in before you can comment on or make changes to this bug.