Closed Bug 1587043 Opened 5 months ago Closed 7 days ago

Intermittent browser/components/urlbar/tests/browser/browser_switchToTab_closes_newtab.js | Found a tab after previous test timed out: https://example.com/browser/browser/components/urlbar/tests/browser/dummy_page.html - | Test timed out

Categories

(Firefox :: Address Bar, defect, P5)

defect

Tracking

()

RESOLVED WORKSFORME
Fission Milestone M4.1

People

(Reporter: intermittent-bug-filer, Unassigned, NeedInfo)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, regression)

Filed by: apavel [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=270252315&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/IR1QR4JKR6CQ4Rv0M382ug/runs/0/artifacts/public/logs/live_backing.log


[task 2019-10-08T10:24:26.108Z] 10:24:26 INFO - TEST-START | browser/components/urlbar/tests/browser/browser_switchToTab_closes_newtab.js
[task 2019-10-08T10:25:11.186Z] 10:25:11 INFO - TEST-INFO | started process screentopng
[task 2019-10-08T10:25:11.715Z] 10:25:11 INFO - TEST-INFO | screentopng: exit 0
[task 2019-10-08T10:25:11.716Z] 10:25:11 INFO - Buffered messages logged at 10:24:26
[task 2019-10-08T10:25:11.716Z] 10:25:11 INFO - Entering test bound test_switchToTab_closes
[task 2019-10-08T10:25:11.717Z] 10:25:11 INFO - Buffered messages finished
[task 2019-10-08T10:25:11.717Z] 10:25:11 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_switchToTab_closes_newtab.js | Test timed out -
[task 2019-10-08T10:25:11.718Z] 10:25:11 INFO - GECKO(11250) | MEMORY STAT | vsize 3259MB | residentFast 354MB | heapAllocated 136MB
[task 2019-10-08T10:25:11.718Z] 10:25:11 INFO - TEST-OK | browser/components/urlbar/tests/browser/browser_switchToTab_closes_newtab.js | took 45088ms
[task 2019-10-08T10:25:11.718Z] 10:25:11 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-10-08T10:25:11.719Z] 10:25:11 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_switchToTab_closes_newtab.js | Found a tab after previous test timed out: https://example.com/browser/browser/components/urlbar/tests/browser/dummy_page.html -
[task 2019-10-08T10:25:11.719Z] 10:25:11 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-10-08T10:25:11.720Z] 10:25:11 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_switchToTab_closes_newtab.js | Found a tab after previous test timed out: http://example.org/browser/browser/components/urlbar/tests/browser/dummy_page.html -
[task 2019-10-08T10:25:11.720Z] 10:25:11 INFO - checking window state
[task 2019-10-08T10:25:11.721Z] 10:25:11 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-10-08T10:25:11.721Z] 10:25:11 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_switchToTab_closes_newtab.js | Uncaught exception received from previously timed out test - at chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_switchToTab_closes_newtab.js:57 - TypeError: Assert is null
[task 2019-10-08T10:25:11.721Z] 10:25:11 INFO - Stack trace:
[task 2019-10-08T10:25:11.721Z] 10:25:11 INFO - test_switchToTab_closes@chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_switchToTab_closes_newtab.js:57:3
[task 2019-10-08T10:25:11.722Z] 10:25:11 INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1345:34
[task 2019-10-08T10:25:11.723Z] 10:25:11 INFO - Tester_execTest@chrome://mochikit/content/browser-test.js:1380:11
[task 2019-10-08T10:25:11.724Z] 10:25:11 INFO - nextTest/<@chrome://mochikit/content/browser-test.js:1208:14
[task 2019-10-08T10:25:11.724Z] 10:25:11 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:805:67

Fission Milestone: --- → M4.1

Closing this bug as WFM because we haven't seen any test failures for two months and this test is not disabled on any platform:

https://searchfox.org/mozilla-central/rev/fca0be7e2cf2f922c9b927423ce28e8a04b3fd90/browser/components/urlbar/tests/browser/browser.ini#110

Status: NEW → RESOLVED
Closed: 7 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.