Closed Bug 1587056 Opened 1 year ago Closed 1 year ago

2.21 - 2.28% tp5o_webext (linux64-shippable, linux64-shippable-qr) regression on push 2c0229c483d89a8073d426f13cc03ab9e59e23a7 (Mon October 7 2019)

Categories

(Core :: DOM: Content Processes, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: Bebe, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(4 keywords)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=2c0229c483d89a8073d426f13cc03ab9e59e23a7

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

2% tp5o_webext linux64-shippable-qr opt e10s stylo 167.38 -> 171.19
2% tp5o_webext linux64-shippable opt e10s stylo 167.64 -> 171.35

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=23377

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/TestEngineering/Performance/Talos

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/TestEngineering/Performance/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/TestEngineering/Performance/Talos/RegressionBugsHandling

Blocks: 1578356
Component: Performance → DOM: Content Processes
Flags: needinfo?(brennie)
Product: Testing → Core
Regressed by: 1578304
Version: Version 3 → unspecified

I dont think there is anything to be done for this. This improvement was noted for the bug 1510569, which introduced bug 1578304. That improvement was likely due to us not actually doing any work and this "regression" is just undoing that "improvement".

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(brennie)
Resolution: --- → WONTFIX
Blocks: 1592626
No longer blocks: 1592626
You need to log in before you can comment on or make changes to this bug.