Closed Bug 158711 Opened 18 years ago Closed 17 years ago

'Show an Alert' (Mail Alert Notification checkbox) should be hidden for Linux / Mac OS

Categories

(SeaMonkey :: MailNews: Message Display, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.4alpha

People

(Reporter: stephend, Assigned: neil)

References

()

Details

(Whiteboard: [adt3])

Attachments

(2 files)

Build ID: Latest trunk, Linux and Mac OS X 10.1.5 / 9.2.2

Summary: Until we have Mail Alert Notification on Mac and Linux platforms, we
should hide the 'Show an alert' checkbox.

Steps to Reproduce:

1.  Use a platform (Mac OS / Linux) that doesn't do the Mail Alert yet, and notice:
2.  Edit / Preferences / Mail & Newsgroups / 'Show an alert' under 'When new
message arrive:'.

Expected Results:

We should hide the following checkbox:

<hbox align="center">
  <checkbox id="newMailNotificationAlert" label="&showAnimatedAlert.label;"
                   prefstring="mail.biff.show_alert"
                   accesskey="&showAnimatedAlert.accesskey;" />
</hbox>

Actual Results:

It remains as a pref.

We should do this for Buffy - sorry this was missed for MachV.
Summary: Mail Alert Notification checkbox should be hidden for Linux / Mac OS → 'Show an Alert' (Mail Alert Notification checkbox) should be hidden for Linux / Mac OS
*** Bug 183528 has been marked as a duplicate of this bug. ***
*** Bug 180305 has been marked as a duplicate of this bug. ***
Mail triage team: nsbeta1+/adt3
Keywords: nsbeta1nsbeta1+
Whiteboard: [adt3]
re-assigning nsbeta1+ bugs
Assignee: mscott → sspitzer
I think the fix for this should be to see if a call to 

getservice("@mozilla.org/alerts-service;1") fails or not.

if it fails, we hide this UI.
Status: NEW → ASSIGNED
this works on win32 and linux.

the reason it does is because of mozilla/xpfe/components/Makefile.in

ifeq ($(OS_ARCH),WINNT)
DIRS		+= winhooks urlwidget alerts
endif

the alerts service is conditionally built, so this code does the right thing.
Comment on attachment 112949 [details] [diff] [review]
testing this patch now...

r+sr=dmose
Attachment #112949 - Flags: superreview+
Attachment #112949 - Flags: review+
Comment on attachment 112949 [details] [diff] [review]
testing this patch now...

a=asa (on behalf of drivers) for checkin to 1.3beta.
Attachment #112949 - Flags: approval1.3b? → approval1.3b+
fixed.

thanks to hiz-ammer for the bug report.
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
This works but it's the wrong fix.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached patch Proposed patchSplinter Review
Comment on attachment 113100 [details] [diff] [review]
Proposed patch

Use of |in| is preferable to try/catch
Attachment #113100 - Flags: superreview?(dmose)
Attachment #113100 - Flags: review?(sspitzer)
Comment on attachment 113100 [details] [diff] [review]
Proposed patch

r/sr=sspitzer

thanks neil.
Attachment #113100 - Flags: superreview?(dmose)
Attachment #113100 - Flags: review?(sspitzer)
Attachment #113100 - Flags: review+
Comment on attachment 113100 [details] [diff] [review]
Proposed patch

Seth, please can I leave it to you to ask for a= if you feel it appropriate?
Attachment #113100 - Flags: superreview?(sspitzer)
Comment on attachment 113100 [details] [diff] [review]
Proposed patch

assuming you tested it well (win32 and linux), sr=sspitzer

let me know if you want help testing this (or any other patch) on a platform
you might not have.
Attachment #113100 - Flags: superreview?(sspitzer) → superreview+
my first fix landed (so this UI won't show in 1.3 beta bits)

I think the code cleanup can wait until the start of 1.3 final.

neil, I'll re-assign to you so you can mark fixed once you check in the code
cleanup.
Assignee: sspitzer → neil
Status: REOPENED → NEW
Target Milestone: --- → mozilla1.3final
Pushing out as I understand that drivers are not accepting cleanup for 1.3final
Target Milestone: mozilla1.3final → mozilla1.4alpha
Fix checked in.
Status: NEW → RESOLVED
Closed: 17 years ago17 years ago
Resolution: --- → FIXED
Trunk build 2003-03-07: Mac 10.1.5, Linux RH 8
Verified Fixed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
Component: MailNews: Notification → MailNews: Message Display
QA Contact: stephend → search
You need to log in before you can comment on or make changes to this bug.