Editing bookmarks info doesn't take effect until clicking on whitespace in Sidebar

VERIFIED FIXED

Status

VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: winnie, Assigned: saari)

Tracking

Details

(Reporter)

Description

17 years ago
07-22 build on OS 10.1.5.

1.  Open sidebar.
2.  Select an existing bookmark.
3.  Click "Edit this Bookmark" button, or context-click on the bookmark and
choose "Get Info".
4.  Edit bookmark dialog comes up.
5.  Change bookmark name and/or location URL.
6.  Close edit bookmark dialog box.

Expected results:  Bookmark name and/or location URL changes.

Actual results:  You need to click on the whitespace below all the bookmarks in
the sidebar for the bookmark name/location URL changes to take effect.  If you
select another bookmark after step 6 instead of clicking on the sidebar
whitespace, your changes will be lost.

I don't believe this is a regression from a recent bookmark fix checkin (bug
155560), since I was able to repro this bug with the 07-16 and the 07-02 builds.
(Reporter)

Updated

17 years ago
Blocks: 154286

Comment 1

17 years ago
WorksForMe using Chimera/20020722.
I think this won't be a problem once the patch in bug 158378 lands.
In fact, somebody will probably complain that the bookmark changes take
effect too quickly.

Checked on a 7/27 NB.  Various bookmark patches have fixed this.  
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
vrfy'd fixed with 2002.07.30.05 nb. after i change the bookmark Name, it's
updated in the sidebar once i navigate out (eg, hit tab) of the Name field.
don't need to dismiss the window, either.
Status: RESOLVED → VERIFIED

Updated

17 years ago
No longer blocks: 154286
You need to log in before you can comment on or make changes to this bug.