Closed Bug 1587362 Opened 3 months ago Closed 3 months ago

PiP button doesn't work after putting tab back in window

Categories

(Toolkit :: Video/Audio Controls, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox71 --- verified

People

(Reporter: valentin, Assigned: mconley)

References

(Regressed 1 open bug)

Details

Attachments

(2 files)

I found this bug on Linux, but it reproduces on Windows too. Seems to happen every time.

STR:

  1. Open youtube video in a new tab - start playing it.
  2. Drag tab out of the tab list, so it opens in a new window
  3. Drag youtube tab back into the original window
  4. Try to click PiP button - Doesn't work. (it clicks through it, pausing the video, instead of popping out).
Priority: -- → P3
Assignee: nobody → mconley
Priority: P3 → P2

It seems that after doing a tab tear out, the WindowRoot ends up changing, so
the mouse button listeners for the toggle end up being attached to the wrong
thing. This patch makes it so that we monitor for tear out/in, and unattach the
mouse button listeners, and then re-attach them on the new WindowRoot after
the tab tear out/in completes.

Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c71f9a59bdfe
Make sure PiP toggle mouse button listeners are attached to the right WindowRoot after tab tear out / in. r=jaws
https://hg.mozilla.org/integration/autoland/rev/d3142d807c7f
Regression test. r=jaws

Here's a try push showing all green with just the fix (and not the test) landed:

https://treeherder.mozilla.org/#/jobs?repo=try&selectedJob=270981716&revision=56963bded2a4f2604efce19d832ea02d364d65cf

I'll re-land the fix, and examine why the test may have caused the spike in oranges.

Flags: needinfo?(mconley)
Keywords: leave-open
Backout by shindli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1c6ab26ee4cf
Backed out 2 changesets for causing very frequent bc failures in toolkit/mozapps/extensions/test/browser/browser_about_debugging_link.js CLOSED TREE

Oops, nevermind - looking at the revision linked to from comment 9, I think pulsebot is referring to the original backout that happened at comment 6. I guess it was just a little late.

Sorry!

Flags: needinfo?(shindli)
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Regressions: 1589370
Flags: qe-verify+

Hello! Reproduced the issue with 71.0a1 (20191009213914) on Windows 10x64 after following the STR from comment 0.
The issue is verified fixed with 71.0b11 (20191118154140) on Windows 10x64, Ubuntu 18.04 and macOS 10.15. After following STR from comment 0 the PiP window is correctly opened.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.