Closed Bug 1587392 Opened 2 years ago Closed 2 years ago

Assertion failure: mPtr <= mRangeEnd

Categories

(Toolkit :: Startup and Profile System, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1587112

People

(Reporter: allstars.chh, Unassigned)

Details

(gdb) bt
#0 0x00007fc59e6bc9d0 in __GI___nanosleep (requested_time=requested_time@entry=0x7ffef1a32a40, remaining=remaining@entry=0x7ffef1a32a40) at ../sysdeps/unix/sysv/linux/nanosleep.c:28
#1 0x00007fc59e6bc8aa in __sleep (seconds=0) at ../sysdeps/posix/sleep.c:55
#2 0x00007fc58f37af3a in ah_crap_handler(int) (signum=11) at /home/allstars/src/gecko/toolkit/xre/nsSigHandlers.cpp:95
#3 0x00007fc58f344bd6 in nsProfileLock::FatalSignalHandler(int, siginfo_t*, void*) (signo=11, info=0x7ffef1a32db0, context=0x7ffef1a32c80)
at /home/allstars/src/gecko/toolkit/profile/nsProfileLock.cpp:178
#4 0x00007fc58fd78bfb in js::UnixExceptionHandler(int, siginfo_t*, void*) (signum=11, info=0x7ffef1a32db0, context=0x7ffef1a32c80)
at /home/allstars/src/gecko/js/src/ds/MemoryProtectionExceptionHandler.cpp:273
#5 0x00007fc590ae95a5 in WasmTrapHandler(int, siginfo_t*, void*) (signum=11, info=0x7ffef1a32db0, context=0x7ffef1a32c80) at /home/allstars/src/gecko/js/src/wasm/WasmSignalHandlers.cpp:962
#6 0x00007fc59f51e890 in <signal handler called> () at /lib/x86_64-linux-gnu/libpthread.so.0
#7 0x00007fc5867c784f in mozilla::RangedPtr<unsigned char>::checkSanity() (this=0x7ffef1a33550) at /home/allstars/src/gecko/obj-x86_64-pc-linux-gnu/dist/include/mozilla/RangedPtr.h:54
#8 0x00007fc5867c7774 in mozilla::RangedPtr<unsigned char>::RangedPtr(unsigned char*, unsigned char*, unsigned char*) (this=0x7ffef1a33550, aPtr=0x7fc59fb36f5c "\200\242\001 \b@\004", aStart=0x7fc59fb2e000 "startupcache0002", aEnd=0x7fc59fb2e015 "") at /home/allstars/src/gecko/obj-x86_64-pc-linux-gnu/dist/include/mozilla/RangedPtr.h:78
#9 0x00007fc5867c75c7 in mozilla::RangedPtr<unsigned char>::create(unsigned char*) const (this=0x7ffef1a33588, aPtr=0x7fc59fb36f5c "\200\242\001 \b@\004")
at /home/allstars/src/gecko/obj-x86_64-pc-linux-gnu/dist/include/mozilla/RangedPtr.h:60
#10 0x00007fc587d3fde9 in mozilla::RangedPtr<unsigned char>::operator+(unsigned long) const (this=0x7ffef1a33588, aInc=36679)
at /home/allstars/src/gecko/obj-x86_64-pc-linux-gnu/dist/include/mozilla/RangedPtr.h:161
#11 0x00007fc58f4075e6 in mozilla::scache::StartupCache::LoadArchive() (this=0x7fc57bcb6100) at /home/allstars/src/gecko/startupcache/StartupCache.cpp:286
#12 0x00007fc58f405286 in mozilla::scache::StartupCache::Init() (this=0x7fc57bcb6100) at /home/allstars/src/gecko/startupcache/StartupCache.cpp:232
#13 0x00007fc58f404954 in mozilla::scache::StartupCache::InitSingleton() () at /home/allstars/src/gecko/startupcache/StartupCache.cpp:132
#14 0x00007fc58f4048dd in mozilla::scache::StartupCache::GetSingleton() () at /home/allstars/src/gecko/startupcache/StartupCache.cpp:119
#15 0x00007fc586718bb6 in NS_InitXPCOM(nsIServiceManager**, nsIFile*, nsIDirectoryServiceProvider*) (aResult=0x7fc57cb30558, aBinDirectory=0x7fc59e362ac0, aAppFileLocationProvider=0x7ffef1a33ec0)
at /home/allstars/src/gecko/xpcom/build/XPCOMInit.cpp:464
#16 0x00007fc58f35e5df in ScopedXPCOMStartup::Initialize() (this=0x7fc57cb30558) at /home/allstars/src/gecko/toolkit/xre/nsAppRunner.cpp:1281
#17 0x00007fc58f36b33a in XREMain::XRE_main(int, char**, mozilla::BootstrapConfig const&) (this=0x7ffef1a33e80, argc=4, argv=0x7ffef1a351e8, aConfig=...)
at /home/allstars/src/gecko/toolkit/xre/nsAppRunner.cpp:4731
#18 0x00007fc58f36bcfb in XRE_main(int, char**, mozilla::BootstrapConfig const&) (argc=4, argv=0x7ffef1a351e8, aConfig=...) at /home/allstars/src/gecko/toolkit/xre/nsAppRunner.cpp:4816
#19 0x00007fc58f3805a7 in mozilla::BootstrapImpl::XRE_main(int, char**, mozilla::BootstrapConfig const&) (this=0x7fc59e3026c0, argc=4, argv=0x7ffef1a351e8, aConfig=...)
at /home/allstars/src/gecko/toolkit/xre/Bootstrap.cpp:45
#20 0x00005558ef35a9b8 in do_main(int, char**, char**) (argc=4, argv=0x7ffef1a351e8, envp=0x7ffef1a35210) at /home/allstars/src/gecko/browser/app/nsBrowserApp.cpp:218
#21 0x00005558ef35a400 in main(int, char**, char**) (argc=4, argv=0x7ffef1a351e8, envp=0x7ffef1a35210) at /home/allstars/src/gecko/browser/app/nsBrowserApp.cpp:300

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1587112
You need to log in before you can comment on or make changes to this bug.