Closed Bug 1587439 Opened 2 years ago Closed 2 years ago

Perma /browser_breachAlertShowingForAddedLogin.js , browser_aaa_eventTelemetry_run_first.js | [JavaScript Error: "Error: Can't find profile directory." {file: "resource://gre/modules/XULStore.jsm" line: 66}] - when Gecko 71 merges to Beta on 2019-10-14

Categories

(Firefox :: about:logins, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- verified

People

(Reporter: NarcisB, Assigned: jaws)

References

(Regression)

Details

Attachments

(1 file)

Central as beta:
https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Crunnable&revision=cb7f32501a17e2dd1003d1ae2b1944658ac613c7&selectedJob=270467210

Log link: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=270466817&repo=try&lineNumber=3372

Log snippet:
[task 2019-10-09T12:36:27.657Z] 12:36:27 INFO - TEST-START | browser/components/aboutlogins/tests/browser/browser_breachAlertShowingForAddedLogin.js
[task 2019-10-09T12:36:29.127Z] 12:36:29 INFO - GECKO(3010) | JavaScript error: resource://gre/modules/XULStore.jsm, line 66: Error: Can't find profile directory.
[task 2019-10-09T12:36:29.143Z] 12:36:29 INFO - GECKO(3010) | JavaScript error: resource://gre/modules/XULStore.jsm, line 66: Error: Can't find profile directory.
[task 2019-10-09T12:36:29.147Z] 12:36:29 INFO - TEST-INFO | started process screentopng
[task 2019-10-09T12:36:29.805Z] 12:36:29 INFO - TEST-INFO | screentopng: exit 0
[task 2019-10-09T12:36:29.806Z] 12:36:29 INFO - Buffered messages logged at 12:36:27
[task 2019-10-09T12:36:29.806Z] 12:36:29 INFO - Entering test bound setup
[task 2019-10-09T12:36:29.806Z] 12:36:29 INFO - Leaving test bound setup
[task 2019-10-09T12:36:29.806Z] 12:36:29 INFO - Entering test bound setup
[task 2019-10-09T12:36:29.806Z] 12:36:29 INFO - Buffered messages logged at 12:36:29
[task 2019-10-09T12:36:29.806Z] 12:36:29 INFO - Console message: [JavaScript Error: "Error: Can't find profile directory." {file: "resource://gre/modules/XULStore.jsm" line: 66}]
[task 2019-10-09T12:36:29.806Z] 12:36:29 INFO - Buffered messages finished
[task 2019-10-09T12:36:29.806Z] 12:36:29 INFO - TEST-UNEXPECTED-FAIL | browser/components/aboutlogins/tests/browser/browser_breachAlertShowingForAddedLogin.js | [JavaScript Error: "Error: Can't find profile directory." {file: "resource://gre/modules/XULStore.jsm" line: 66}] -
[task 2019-10-09T12:36:29.806Z] 12:36:29 INFO - Stack trace:
[task 2019-10-09T12:36:29.806Z] 12:36:29 INFO - chrome://mochikit/content/browser-test.js:test_ok:1575
[task 2019-10-09T12:36:29.806Z] 12:36:29 INFO - chrome://mochitests/content/browser/browser/components/aboutlogins/tests/browser/head.js:onConsoleMessage:109
[task 2019-10-09T12:36:29.806Z] 12:36:29 INFO - resource://specialpowers/SpecialPowersChild.jsm:observe/<:137
[task 2019-10-09T12:36:29.806Z] 12:36:29 INFO - Console message: [JavaScript Error: "Error: Can't find profile directory." {file: "resource://gre/modules/XULStore.jsm" line: 66}]
[task 2019-10-09T12:36:29.806Z] 12:36:29 INFO - Not taking screenshot here: see the one that was previously logged

Flags: needinfo?(MattN+bmo)

[Tracking Requested - why for this release]:

Component: Password Manager → about:logins
Flags: needinfo?(MattN+bmo) → needinfo?(jaws)
Product: Toolkit → Firefox
Regressed by: 1576501
Summary: Perma browser/components/aboutlogins/tests/browser/browser_breachAlertShowingForAddedLogin.js | [JavaScript Error: "Error: Can't find profile directory." {file: "resource://gre/modules/XULStore.jsm" line: 66}] - when Gecko 71 merges to Beta on 2019-10-14 → Perma /browser_breachAlertShowingForAddedLogin.js , browser_aaa_eventTelemetry_run_first.js | [JavaScript Error: "Error: Can't find profile directory." {file: "resource://gre/modules/XULStore.jsm" line: 66}] - when Gecko 71 merges to Beta on 2019-10-14
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)
Depends on: 1547877
Priority: -- → P2

This should be P1 since it will block the merge of 71. Since m-c is now 71 P1 means it must be fixed in 71.

Priority: P2 → P1
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d7e83d739e26
Ignore messages about missing profile in old XULStore.jsm. r=sfoster
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
You need to log in before you can comment on or make changes to this bug.