Keeping object focus when changing browser tabs

RESOLVED DUPLICATE of bug 120148

Status

SeaMonkey
General
--
enhancement
RESOLVED DUPLICATE of bug 120148
16 years ago
13 years ago

People

(Reporter: Matt Greco, Assigned: Matti)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When changing tabs using Ctrl-PgUp and Ctrl-PgDn, whatever object was focused on
to begin with in the original tab loses focus when switching back.  For example,
if posting something on a message board, and switching tabs to look up some
additional information, when switching back to the message board tab, the cursor
will no longer be in the same place.

This can be easily reproduced in bugzilla.  Open two tabs, one with a new bug
report, and the other can be anything.  Start typing in the description field,
and then use Ctrl-PgDn to change to the empty tab...then, use Ctrl-PgDn to
change back to the bugzilla tab...the cursor will no longer be in the
description field.

It would be very helpful to have the focus be remembered, so that when you come
back to each tab, you would be where you left off...in this example, when you
switch back to the bugzilla tab, the cursor should still be exactly where you
left it, in the description field.
Duplicate of "Tabs don't remember which element was focused when switching tabs"

*** This bug has been marked as a duplicate of 120148 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.