If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

about: does not show updated version when updated from xpis

RESOLVED INVALID

Status

Core Graveyard
Installer: XPInstall Engine
RESOLVED INVALID
15 years ago
2 years ago

People

(Reporter: Satyajit Rai, Assigned: dveditz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
I had a nightly build of mozilla installed (dated 29th May 2002) on my machine.
After the official release of Mozilla 1.0, I updated mozilla by using xpis. But
the browser still shows Build ID: 2002052918 in the about: page. The same build
id also appears on the top explorer bar.

Comment 1

15 years ago
It can sound like you have two different builds installed.
Was your previous installation done in the same way? Or was it an rpm, for
instance? (tar.gz or installer builds and rpm builds install to different
directories)
And be sure that you have no old XPIs in the same directory while installing...
(Reporter)

Comment 3

15 years ago
My previous installation was using rpm package and current one was by
downloading the tar.gz and using the installer script. I did not have any old
xpi files in the directory when I installed the later version.
Do you override the UA string in "prefs.js" ?

Comment 5

15 years ago
live upgrading browser.xpi?
Assignee: Matti → dveditz
Component: Browser-General → Installer: XPInstall Engine
QA Contact: asa → jimmylee

Comment 6

15 years ago
Satyajit, are you still experiencing this problem?

You might check to see if you have the environment variable MOZILLA_FIVE_HOME
set to something. I've seen at least one linux distribution which sets that
variable to point to the system copy of mozilla.

If MOZILLA_FIVE_HOME is set, the "mozilla" script will launch the copy of
mozilla from the specified directory, instead of launching the copy that goes
with the mozilla script you're running. This might explain what you reported.

Comment 7

15 years ago
No response from the reporter. Satyajit, if you think this is still an issue
with current revisions of mozilla, please feel free to reopen this report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.