Closed Bug 1587549 Opened 3 years ago Closed 3 years ago

Thunderbird 68 lacks native support for minimize/close to tray/panel and breaks nearly all AddOns that provide it

Categories

(Thunderbird :: Untriaged, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1486221

People

(Reporter: signupemail, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

Tried to keep Thunderbird running in the background - on my panel or on my tray. It makes sense to run an e-mail client in the background like that, doesn't it? (One can simply minimise Thunderbird, but what is wanted is that Thunderbird keep running when the close button is pressed.)

Actual results:

Without any AddOn providing the functionality: what I want is impossible. And at present all AddOns that provide this feature - except one that is Linux only and that one must build oneself - have been broken by changes to Thunderbird.

Expected results:

I should be able to minimize to tray/taskbar what have you - even when using the close button. (Why? Well, for one thing, users of those AddOns have got used to it. Thus, the change is 'breaking userspace.')

In one of the several bug reports (#1486221) devoted to this issue, a developer writes: 'we've got the message. ' That was ten months ago. Also: I hear Thunderbird is going to incorporate the AddOn Enigmail. Well, why not do the same with one of the MinimizeToTray extensions?

It is great to have interest - but please refrain from creating duplicate bug reports.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1486221

Is someone working on this issue?

(In reply to elelont2 from comment #2)

Is someone working on this issue?

This bug has been resolved as a duplicate of bug 1486221 which you can review and follow.

You need to log in before you can comment on or make changes to this bug.