Closed Bug 158786 Opened 19 years ago Closed 19 years ago

Form loading in background tab steals focus from URL bar in foreground tab

Categories

(SeaMonkey :: Tabbed Browser, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 124750

People

(Reporter: niederstrasser, Assigned: jag+mozilla)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020722
BuildID:    1.1beta (2002072204)

When loading a tab in the background that has a form with autofocus, the form
steals the focus from the URL bar when the URL bar is active for the foreground tab.


Reproducible: Always
Steps to Reproduce:
To easily test, this requires a connection that is slow enough (56K shows bug)
to allow switching to the 2nd tab and typing a URL before the first tab is fully
loaded.

1. Open two empty tabs
2. On the first tab, go to a page that has a form with automatic focus onload.
http://mail.yahoo.com/ is a good example.
3. As soon as the page starts loading, move to the 2nd tab, click on the URL bar
and start typing any URL.

Actual Results:  When the 1st tab is fully loaded (in the background), the form
steals the keyboard focus. Anything typed into the URL bar in the foreground tab
is instead typed into the focused form field in the background tab.

Expected Results:  The form in the background tab should not steal focus from
the foreground tab.

Doing the same steps but in two separate windows does not steal the keyboard focus.

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.