Closed Bug 1587936 Opened 9 months ago Closed 5 months ago

WebXR: Replace XR.supportsSession() with XR.isSessionSupported()

Categories

(Core :: WebVR, task, P2)

task

Tracking

()

RESOLVED DUPLICATE of bug 1614499

People

(Reporter: sheppy, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: dev-doc-needed)

The supportsSession() method has been replaced with the isSessionSupported() session. Its operation is somewhat different, in that instead of resolving an empty promise on success, it now resolves with a Boolean true if the session mode is supported; otherwise it resolves with false.

Exceptions are now thrown only for errors.

Type: defect → task
Priority: -- → P2

The biggest issue with this is that most of the samples I find online have already been updated to use isSessionSupported(), so since we don't have that the samples fail to work. That may be off-putting to some developers, and it certainly slows down progress on trying to onboard as a developer.

Bug 1614496 includes this as part of the WebXR core implementation

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1614499
You need to log in before you can comment on or make changes to this bug.