Closed Bug 1588046 Opened 4 months ago Closed 3 months ago

The Mobile Promotion is wrongly displayed in the center of the “about:logins” page instead of the bottom part of it

Categories

(Firefox :: about:logins, defect, P3)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- disabled
firefox70 --- unaffected
firefox71 --- verified

People

(Reporter: simona.rosu, Assigned: jaws)

References

Details

(Keywords: regression, Whiteboard: [passwords:management] [skyline])

Attachments

(2 files)

Attached image MobilePromotion.PNG

[Affected versions]:

  • Latest Firefox Nightly 71.0a1 (Build ID: 20191010214019) (64-bit)

[Affected Platforms]:

  • Mac 10.14
  • Windows 10 x64
  • Ubuntu 16.04 x64

[Prerequisites]:

  • Have a new Firefox profile.
  • Have a valid Firefox Account with multiple logins saved.

[Steps to reproduce]:

  1. Open the browser with the profile from prerequisites.
  2. Navigate to the "about:logins" page.
  3. Click on the “Sign in to Sync” button.
  4. Enter the credentials from the prerequisites and log in.
  5. Go back to the “about:logins” page and create a new login.
  6. Observe the Mobile Promotion.

[Expected result]:

  • The Mobile Promotion is displayed on the bottom of the page.

[Actual result]:

  • The Mobile Promotion is wrongly displayed on the center of the page.

[Regression]

  • The issue is not reproducible with older Nightly 71.0a1 builds. Considering this, using mozregression tool I have found the issue that broke this in the latest Nightly build. Here are the results:
  • Pushlog: https://tinyurl.com/y2benyvj
  • Last good revision: 263936aecc1dcd15f9dadbf4e41f7e7eebad29a6
  • First bad revision: ab46062892d418b37dbfa35fc3a61db5f7c9de59

[Notes]:

  • Attached a screenshot with the issue.
  • @Jared, could you please take a look over this issue?
Flags: needinfo?(jaws)
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)
Priority: -- → P3
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cb426a0d9484
Flex the login-item so the form can grow to consume the remaining space and push the footer to the bottom of the grid area. r=sfoster
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

I have verified this issue on the latest Nightly 71.0a1 (Build ID: 20191015213743) on Windows 10 x64, Mac 10.14, Ubuntu 16.04 x64.

  • The Mobile Promotion is correctly displayed in the bottom part of the “about:logins” page.
Status: RESOLVED → VERIFIED
Regressions: 1589324
You need to log in before you can comment on or make changes to this bug.