Closed Bug 1588091 Opened 2 years ago Closed 2 years ago

test_autocomplete_https_downgrade.html fails with fission enabled

Categories

(Toolkit :: Password Manager, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1556627
Fission Milestone M4.1

People

(Reporter: MattN, Unassigned)

References

Details

The tests run but synthesizeKey is sending the event to the wrong child frame. Could be a focus issue. It works if I focus then press the expected keys manually.

Depends on: 1588095
Summary: test_autocomplete_https_upgrade.html fails with fission enabled → test_autocomplete_https_downgrade.html fails with fission enabled

Tentatively moving all bugs whose summaries mention "Fission" (or other Fission-related keywords) but are not assigned to a Fission Milestone to the "?" triage milestone.

This will generate a lot of bugmail, so you can filter your bugmail for the following UUID and delete them en masse:

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: --- → ?

Blocks Fission mochitests milestone (M4.1)

Fission Milestone: ? → M4.1

The best solution is to have the test harness support loading tests over http on port 80, changing scheme = http to do that and have scheme = default use mochi.test:8888 like we do now.

Depends on: 1556627

Matt, this bug is a blocker for Fission's current milestone (M4.1 aka "fix all the mochitests"), but it's currently unassigned. The Fission team is hoping teams will fix their mochitests for Fission before the end of Q1 (75 or 76 Nightly).

Will your team be able to prioritize this bug for Q1? Do we need a different team to make the test harness changes for scheme = http that you recommended in comment 3?

If you don't think this mochitest failure should block shipping Fission, just let me know. If you have questions for Fission engineers, you can reach them in the #fission channel on Slack or Riot.

Flags: needinfo?(MattN+bmo)

I believe this is getting fixed by bug 1556627 which is in review. Then we won't need the fix from comment 3.

Flags: needinfo?(MattN+bmo)

(In reply to Matthew N. [:MattN] (PM me if request are blocking you) from comment #5)

I believe this is getting fixed by bug 1556627 which is in review. Then we won't need the fix from comment 3.

Cool. After bug 1556627 lands, we'll still need someone to re-enable this test_autocomplete_https_downgrade.html test for Fission here:

https://searchfox.org/mozilla-central/rev/1db5ef59eba65d32d6a29a494e87b6078453e559/toolkit/components/passwordmgr/test/mochitest/mochitest.ini#35-36

(In reply to Chris Peterson [:cpeterson] from comment #6)

(In reply to Matthew N. [:MattN] (PM me if request are blocking you) from comment #5)

I believe this is getting fixed by bug 1556627 which is in review. Then we won't need the fix from comment 3.

Cool. After bug 1556627 lands, we'll still need someone to re-enable this test_autocomplete_https_downgrade.html test for Fission here:

https://searchfox.org/mozilla-central/rev/1db5ef59eba65d32d6a29a494e87b6078453e559/toolkit/components/passwordmgr/test/mochitest/mochitest.ini#35-36

No, that's being done in that bug: https://phabricator.services.mozilla.com/D55651#change-0luLql5AjcUY

(In reply to Matthew N. [:MattN] (PM me if request are blocking you) from comment #7)

No, that's being done in that bug: https://phabricator.services.mozilla.com/D55651#change-0luLql5AjcUY

Thanks. In that case, I'll close this bug as a dupe of bug 1556627.

Status: NEW → RESOLVED
Closed: 2 years ago
No longer depends on: 1556627
Resolution: --- → DUPLICATE
Duplicate of bug: 1556627
You need to log in before you can comment on or make changes to this bug.