Closed Bug 1588149 Opened 4 months ago Closed 3 months ago

Crash in [@ std::_Function_handler<T>::_M_invoke]

Categories

(Core :: DOM: Service Workers, defect, critical)

Unspecified
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1587794

People

(Reporter: mccr8, Assigned: perry)

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-7b6ff995-5804-42ae-9c64-a716b0191009.

Top 10 frames of crashing thread:

0 libxul.so std::_Function_handler&lt;void  /builds/worker/fetches/clang/include/c++/6.4.0/functional:1731
1 libxul.so std::_Function_handler&lt;void  /builds/worker/fetches/clang/include/c++/6.4.0/functional:1731
2 libxul.so mozilla::dom::PServiceWorkerRegistrationChild::OnMessageReceived /builds/worker/fetches/clang/include/c++/6.4.0/functional:2127
3 libxul.so mozilla::ipc::PBackgroundChild::OnMessageReceived ipc/ipdl/PBackgroundChild.cpp:5876
4 libxul.so mozilla::ipc::MessageChannel::DispatchMessage ipc/glue/MessageChannel.cpp:2185
5 libxul.so mozilla::ipc::MessageChannel::RunMessage ipc/glue/MessageChannel.cpp:1954
6 libxul.so mozilla::ipc::MessageChannel::MessageTask::Run ipc/glue/MessageChannel.cpp:1985
7 libxul.so nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1225
8 libxul.so &lt;name omitted> xpcom/threads/nsThreadUtils.cpp:486
9 libxul.so mozilla::ipc::MessagePump::Run ipc/glue/MessagePump.cpp:110

This is the top non-hang Linux crash for 10/9, in Service Worker code.

The crash reason is: MOZ_DIAGNOSTIC_ASSERT(global)

Maybe this is the Linux variant of bug 1578919?

Flags: needinfo?(perry)

Doesn't look like the same code path as the cause of bug 1578919.

Andrew, the stack trace shows this MOZ_DIAGNOSTIC_ASSERT firing, but there's no DOMMozPromiseRequestHolders for parent-intercept code (RemoteServiceWorkerRegistrationImpl specifically), unlike child-intercept ServiceWorkerRegistration{Main,Worker}Thread. So I think RemoteServiceWorkerRegistrationImpl and friends are missing DOMMozPromiseRequestHolders?

Flags: needinfo?(perry) → needinfo?(bugmail)

I hit this by going to https://www.sammobile.com/2019/03/13/is-the-galaxy-s10-waterproof-what-ip68-means/ and refreshing the page multiple times.

Assignee: nobody → perry
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1587794
Flags: needinfo?(bugmail)
You need to log in before you can comment on or make changes to this bug.