If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

vub.sk - [LAYER]hideAll is not defined

RESOLVED FIXED

Status

Tech Evangelism Graveyard
Other
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: Marcel Telka, Assigned: Pavol Vaskovic)

Tracking

Details

(Whiteboard: BANK, URL)

(Reporter)

Description

15 years ago
Please surf to http://www.vub.sk/ with Mozilla 1.0...

This error is displayed:

[JavaScript Application]
Error: hideAll is not defined
File: template.html
Line: 0

With IE6.0 page works ok. Evangelism?

Comment 1

15 years ago
Yes, this is Evangelsim. From http://www.vub.sk/Js/std.js:

            var NS4 = (document.layers);
            var IE4 = (document.all);
            var IE5 = (IE4 && navigator.appVersion.indexOf("5.")!=-1);
            var IE55 = (IE4 && navigator.appVersion.indexOf("5.5")!=-1);
            var IE = IE4||IE5||IE55;
            var ver4 = (NS4 || IE4);
            var isMac = (navigator.appVersion.indexOf("Mac") != -1);
            var isMenu = (NS4 || (IE4 && !isMac) || (IE5 && !isMac));



Note that in Mozilla, |isMenu| will evaluate to false, since
neither |document.layers| nor |document.all| are supported!!!


This causes trouble at the given URL:

if (isMenu) 
{
  document.write("<SCRIPT LANGUAGE='JavaScript1.2' SRC='JS/mil_menu.js'                           
                          TYPE='text/javascript'><\/SCRIPT>");
}


Because |isMenu| is false in Mozilla, this external script never gets
Hence all the functions in this file are undefined in Mozilla.

Hence all the errors at the site -
Assignee: rogerl → piskozub
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → Europe: Central
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: pschwartau → pali
Version: other → unspecified

Comment 2

15 years ago
There is a typo in my comment above. It should be:

          "...this external script never gets loaded"
Summary: hideAll is not defined → [LAYER]hideAll is not defined

Comment 3

15 years ago
Reassinging to Pavol. Making myself the QA.
Assignee: piskozub → pali
QA Contact: pali → piskozub
(Assignee)

Comment 4

15 years ago
This is Bank. I'll try comunicating with them i the first round.
Status: NEW → ASSIGNED
Whiteboard: BANK

Comment 5

15 years ago
*** Bug 189748 has been marked as a duplicate of this bug. ***
Summary: [LAYER]hideAll is not defined → vub.sk - [LAYER]hideAll is not defined
*** Bug 173011 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
*** Bug 209644 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
-> other
Component: Europe: Central → Other
Seems that this page has been redesigned and works ok in Mozilla.

Comment 10

14 years ago
It does not work for me (a zillion JavaScript popup windows).

Tested with Mozilla 1.5b on WindowsME.
(Assignee)

Comment 11

14 years ago
WFM. Tested in Mozilla 1.5a and Mozilla Firebird 0.6.1 on Win2k.
No errors at all. Jacek, can you describe your problem in detail?

Comment 12

14 years ago
I checked from a different computer (same OS & Mozilla version) and I do not see
the problem. Strange.

Marking as Fixed, then.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.